WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress URL location changed and blog ruined. (4 posts)

  1. 4evrblu
    Member
    Posted 7 years ago #

    Under options I made a GRAVE error.

    I changed the WordPress address from http://mysite.com/wordpress/ to http://mysite.com/

    I did this trying to change the Location of my BLOG address and now it has totally screwed my blog up. Please tell me I do not have to rebuild it.

  2. whooami
    Member
    Posted 7 years ago #

    this will help,

    http://www.tamba2.org.uk/wordpress/site-url/

    your problem is neither new nor unique. In the future, if you have other problems, its always best to search first.

  3. 4evrblu
    Member
    Posted 7 years ago #

    The gesture and suggestion are apprectiated and noted. However I did not really know what search terms to use. So, I posted out of desparation. I am SO glad I did not delete my blog though, and I learned something that may be very helpful to someone in the near future. I fixed the issue!! And here is what I did.

    Basically, what I had done was conduct an experiment without realizing what it would do.

    I had followed the instructions in this codex "how-to" guide: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    I did this in order that my blog which is located at http://mysite.com/wordpress/ could be accessed by typing the root url : http://mysite.com/

    To accomplish this I uploaded a slightly altered index.php, along with a .htaccess file, to my ROOT directory http://mysite.com/, which obiously resides one level up from http://mysite.com/wordpress directory (which is where every other wordpress file is located). The combination of the newly placed index.php and htaccess file had the effect of allowing someone to go to http://mysite.com/ and have that URL remain static throughout their browsing experience. It works like a charm.

    However, PodPress does not recognize this. Or if it does I have yet to find out how to make it see http://mysite.com/ as my URL instead of http://mysite.com/wordpress.

    This is bad because podpress sends a ton of information to iTunes, including what it THINKS is the wordpress blog url. Since the directory http://mysite.com/wordpress/ contained no index.php or htaccess file (I had changed them to indexold.php and htaccessold for safe measure), http://mysite.com/wordpress/ returned a bad url error. Make sense so far?

    SOOOOOO..........

    Me being the smartass I am, I decided to outthink Podpress. I went into OPIONS and changed the the WordPress address (URI): location from http://mysite.com/wordpress/ to http://mysite.com/ . My thinking was that this was the only way to get PodPress to send the homepage url I desired to iTunes. That way when people tried to link back to my hp from iTunes, iTunes would send them to http://mysite.com/, which is where I wanted them to go. Problem is, Podpress kept telling iTunes that my hp url was http://mysite.com/wordpress/ instead. With me so far?

    So, back to amin options.

    I clicked update options to change the WordPress address (URI): value from http://mysite.com/wordpress/ to http://mysite.com/, and when I did...BLAMMO! That was all she wrote.

    All of the sudden none of my links worked. I mean NONE of them. All of my pages had no styles associated with them. Not even my admin pages looked right. For example, http://mysite.com/wordpress/wp-login.php had no WP logo image, no styles....nothing.

    Further complicating the issue was this little gem: Everytime I put my mouse over a link I wanted to go to, the browser saw http://mysite.com/whateverfile.php, which of course no longer worked because of my teeny, weeny alteration. I was getting 404 errors everywhere I clicked, or pages with no styles, you name it, I was getting it. All because of that one stupid mistake in Options moments earlier.

    Obviously I had to think fast.

    My first reaction was to delete the blog and start over, but this was an aweful option.

    My second thought was to remove the new index.php and new htaccess files that I had placed in my root. This would force any browser to default to the WELCOME.HTML page in my root, which it did. However, I wanted to fix this problem, so I also needed to go back into http://mysite.com/wordpress/ (using an ftpprogram )and rename the indexold and htaccessold files back to their original names: index.php and htaccess

    My hope was that when I went to http://mysite.com/wordpress/ my browser would see the index.php file. It did. Sort of.

    The styles were still gone and this told me that more work needed to be done at the Admin level. This meant that I had to change settings by logging into my blog as admin. But this was not so easily done.

    I had to manually type http://mysite.com/wordpress/wp-login.php into my browser and clicked enter, which took me to the login page, sans the styles and images, of course. I clicked login. I got in to my Dashboard. Whew.

    Still, there were no styles, no images. No buttons. Just unstyled text on a white background that ran vertically along the left hand side of my browser window.

    I looked for the link that said OPTIONS and moused over it. I noticed that my status bar on the bottom of my browser was reading http://mysite.com/wp-admin/options-general.php instead of http://mysite.com/wordpress/wp-admin/options-general.php . It was clear I would need to manually type all my links if I wanted to navigate this broken site.

    I manually typed http://mysite.com/wordpress/wp-admin/options-general.php to take me to the right page, and it did. Again, no styles, no nothing. Plain text. But at least I was where I needed to be.

    I scrolled way down to locate the WordPress address (URI): field. Inside it was http://mysite.com/

    I changed WordPress address (URI): field to http://mysite.com/wordpress/ , left the BLOG address (URI): set to http://mysite.com/, clicked the update options button, and boom. I had styles, background, everything. I was home again. That fixed it. No need to rebuild the blog, no issues with my database. Nothing.

    However, I still wanted http://mysite.com/ to resolve where I wanted, but without the problems podpress and iTunes were giving me. So, I gave WordPress its root blog directory again. I uploaded index.php and htaccess to my root, but this time I did not alter the primary index.php or htaccess files inside my http://mysite.com/wordpress/ folder. I left them untouched. That way, if by some chance someone came to http://mysite.com/wordpress/ by mistake, there was an index.php file inside the folder waiting for them. They could then get into my blog without a problem. In the end, the iTunes link to http://totalphysiqueonline.com/wordpress/ works, and so does http://totalphysiqueonline.com/

    which is what the search engines will see.

    Resolved. Hope this helps.

  4. 4evrblu
    Member
    Posted 7 years ago #

    Thanks again.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags