WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] wordpress thinks everything is spam (11 posts)

  1. thequietstorm
    Member
    Posted 6 years ago #

    i'd been having a lot of problems with spam comments on my blog. as a result, i added a lot of words to the comment blacklist, and made sure i marked all spam comments as spam instead of just deleting them.

    now people are telling me they are not able to comment on my blog because they are getting a message that says their comment contains a spam word. i erased all the words in the comment blacklist, but the problem is still happening. is there any way to erase wordpress's memory of what is spam so i can just start from scratch?

  2. moshu
    Member
    Posted 6 years ago #

    What kind of anti-spam plugins are you using?

  3. thequietstorm
    Member
    Posted 6 years ago #

    js spam block

  4. moshu
    Member
    Posted 6 years ago #

    Well, if you still have a lot of spam... obvioulsy it doesn't work.
    Try Akismet, BadBehavior, SpamKarma2 - BB with any one of the two others should make you spam free.

  5. thequietstorm
    Member
    Posted 6 years ago #

    but it's still not allowing my readers to comment without telling them they're spamming me. that's the main problem at hand here....i can deal with spam, as long as i can get real comments too.

  6. moshu
    Member
    Posted 6 years ago #

    Error: Wrong anti-spam word.

    This is the error msg I got.
    It seems to be a WP message. There is a blacklist row in the wp_options table in the database... You may want to look into it - what is the wrong word.

    Also, does that plugin using the DB to store spam and blacklist? If yes, did you try to delete everything from the tables?

  7. thequietstorm
    Member
    Posted 6 years ago #

    right now the only word in there is prescription.

    i didn't notice any tables created by the plugin...but i disabled that plugin right after my second post in this thread anyway.

  8. whooami
    Member
    Posted 6 years ago #

    youre using a plugin but it appears you havent followed the directions .. since they (http://wordpress.org/extend/plugins/jsspamblock/installation/)
    say :

    4.Try leaving a comment on one of your posts. If everything went properly, you won't even notice a difference. Search the page's source code for jsspamblock to make sure the code is included in the page. Please make sure you make a test comment to be sure it is working properly.

    I've searched your this page:

    http://quiet-storm.org/blog/?p=99#respond

    and I dont see that.

    If you look at the images here:

    http://wordpress.org/extend/plugins/jsspamblock/screenshots/

    also, you will notice that there ought to be a box for people to put a number -- without the box, theres no number, so theyre not allowed to comment...........................................................................

    Follow the !!instructions!!, they tell you what to do in this case. Those instructions can be found here (again):

    http://wordpress.org/extend/plugins/jsspamblock/installation/

    and in that file called README.txt that is in the zip you downloaded.

    Its called a readme for a reason ;)

    --

    I disabled my javascript to compare what the images showed, btw.

  9. thequietstorm
    Member
    Posted 6 years ago #

    i did do a test comment and everything worked fine. i just delete them when i'm done. i've never actually seen the error message myself. i'll check it all out anyway.

    besides, like i said, i went ahead and disabled all plugins, hoping that would help the situation. i think the problem is a problem with wordpress itself, not with any plugins -- as i have none activated but the problem still remains.

  10. whooami
    Member
    Posted 6 years ago #

    actually, I owe you an apology.

    the error you are seeing isnt being caused by that plugin - so for everything I said above, I am sorry.

    Your error is being caused by the OTHER plugin you are using -- Cryptographp

    It 'appears', outwardly, that <?php display_cryptographp(); ?> hasnt been added to your comments.php

    If you have added that bit, and the captcha isnt showing up, your host might not have GD support compiled into PHP, in which case youre going to have a tough time using that as a spam solution.

    Rather than muck around with these little plugins, follow Moshu's advice above :)

  11. thequietstorm
    Member
    Posted 6 years ago #

    thanks so much. i deactivated it and will have the people who were having problems commenting try it again.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags