WordPress.org

Ready to get started?Download WordPress

Forums

WordPress theme not showing up on mobile devices (6 posts)

  1. tokyographer
    Member
    Posted 1 year ago #

    Hi,

    I use wordpress on 2 websites and both show correctly on pc, but on mobile devices, iphone, ipad, etc, the css is not loading and the blog is not loading the most recent posts.

    One site is a photography website that uses the Photocrati theme and the other a marketing blog using the Genesis theme.
    I use these plugins.
    -WordPress SEO by Yoast
    -W3C Total Cache
    -and Cloudflare CDN.

    If you check this site http://mediared.es
    the theme works properly on PC but on mobile devices it is loading the previous template I had installed, not the current Genesis one.

    And on this photography site http://tokyography.com posts are outdated on mobile devices.

    Dont know how to solve this problem it seems like a cache problem or probably a Cloudflare issue. If anyone has any clues let me know!

    Thanks!
    Tony

  2. For Genesis questions, please go to the support forums at http://www.studiopress.com/support/

  3. Rev. Voodoo
    Volunteer Moderator
    Posted 1 year ago #

    HAve you also purged your cloudflare? It can be pretty aggressive sometimes

    Even after purging, I've had to turn on developer mode - which fixes my problem (developer mode auto expires after 3 hours, it bypasses any cloudflare caching)

  4. damoncloudflare
    Member
    Posted 1 year ago #

    If you make changes to your site's static content (images, css, javascript, etc.), then you need to go to CloudFlare's Development Mode first (settings->development mode). You can also purge your cache as an additional option in your settings.

  5. leighdunn
    Member
    Posted 1 year ago #

    Hi, I need help with an issue i'm having. I had some technical support from bluehost change my wordpress and address url to "http://sunshineandbananas.com" however since then my site is no longer displaying correctly on my ipad. I'm using the Desire theme and it was working fine but now the side bar and header are missing. Can anyone help. Please keep in mind i am not very technical!

  6. Andrew
    Forum Moderator
    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Topic