WordPress.org

Ready to get started?Download WordPress

Forums

WordPress takes about one minute to load (due to slow code execution) (1 post)

  1. jpod
    Member
    Posted 4 years ago #

    After freshly installing WordPress on a LAMP system (details follow) I found the new site to take about a minute to load. Investigation showed that the problem lies with wp-settings.php, more precisely with the function call do_action('sanitize_comment_cookies') (line 594): this call takes almost exactly 60 seconds to execute. If (and only if) it's commented out, the whole page is generated in under one second.

    I couldn't conduct any further analysis, since I'm not familiar with the inner workings of WordPress; but the fact that this function takes exactly 60 seconds to execute suggests to me that some kind of timeout is involved.

    I've conducted my testing with PHP from the command line, with all plugins disabled. The system is a Debian 4.1/Etch-box, as follows:

    • WordPress: 2.8.6
    • PHP: 5.2.0-8+etch16, Zend Engine v2.2.0, with eAccelerator v0.9.5.3
    • Linux version: 2.6.18-6-xen-amd64 (Debian 2.6.18.dfsg.1-24etch4) (dannf@debian.org) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21))

    While this should not matter to the problem at hand:

    • Apache: 2.2.3
    • MySQL: 5.0.32-Debian_7etch11-log

    Any help would be greatly appreciated, even if you cannot tell me how to resolve that issue, so to speak, cleanly (which, needless to say, would be preferred), it would already be helpful if anybody knew what exactly do_action('sanitize_comment_cookies') is good for, i.e., whether it can be be commented out safely. Other ideas for workarounds are also welcome (I've already installed WP Super Cache and WP Widget Cache, so you need not suggest that).

    Thx.

Topic Closed

This topic has been closed to new replies.

About this Topic