WordPress.org

Ready to get started?Download WordPress

Forums

Social Media Widget
WordPress site down after upgrade (39 posts)

  1. kmg454
    Member
    Posted 1 year ago #

    Today my wordpress dashboard say update your plugin, after update my website was down. Deactivate brought the website back online.

    http://wordpress.org/extend/plugins/social-media-widget/

  2. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

    Not sure why that would happen. When you say down, what exactly happened?

  3. kmg454
    Member
    Posted 1 year ago #

    Website came back with a timeout message.

    Below I found in the logfile of the server

    [Mon Feb 04 16:43:44 2013] [warn] (103)Software caused connection abort: mod_fcgid: ap_pass_brigade failed in handle_request function
    [Mon Feb 04 16:44:32 2013] [warn] (110)Connection timed out: mod_fcgid: ap_pass_brigade failed in handle_request function

  4. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

    I'd contact your web host about this, I don't think it's a problem with the plugin.

  5. kmg454
    Member
    Posted 1 year ago #

    You can not contact my webhost because we are the webhost of our own servers.

    I'm sure it's a problem with this plugin, just upgraded this plugun on another website and server and the same thing happens, deactivate the plugin solved the problem again.

  6. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

    It's something to do with how your server is setup. This is the first case of this happening (that I know of). Some setting in apache or php on your server is causing this, the plugin is not at fault. I do not know what the fix is but some googling should clear it up.

  7. stonesleep
    Member
    Posted 1 year ago #

    Same thing happened to me where I updated this plug-in on one of our development sites, and it took the entire install down. Had to go in, deactivate every plug-in, then restore everything one by one until I found the culprit. I have since had to revert back to version 2.9.8 in order to get it back into the site.

  8. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

    Strange...can you guys let me know your apache and php versions?

  9. kmg454
    Member
    Posted 1 year ago #

    It's running on a Plesk server in FastCGI mode with PHP 5.3.16-1

  10. stonesleep
    Member
    Posted 1 year ago #

    Apache Version 2.2.22
    PHP Version 5.3.14

  11. stonesleep
    Member
    Posted 1 year ago #

    Also, if it matters, I"m running cPanel on my server

  12. kmg454
    Member
    Posted 1 year ago #

    Apache Version Apache/2.2.22 (Unix)

  13. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

    Have you tried manually installing the plugin?

  14. kmg454
    Member
    Posted 1 year ago #

    Yes same problem, when use an older version the problem is gone.

  15. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

    So the error occurs during activation? Is it a 500 error?

  16. kmg454
    Member
    Posted 1 year ago #

    Finaly after a timeout there is an 500 error on the screen.

  17. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

    Can you check out this page and try to implement the fixes it mentions?

    http://www.moe.co.uk/2010/04/12/mod_fcgid-ap_pass_brigade-failed-and-premature-end-of-script-headers/

  18. kmg454
    Member
    Posted 1 year ago #

    I do not change anything on my server, there are 350 websites on this server and they all run fine. So I don't want to change this to get a plugin to work. If there is no solution I go to use another plugin for social media buttons.

  19. stonesleep
    Member
    Posted 1 year ago #

    Same, I have a ton of sites in multiple stages of development running on my server (not to mention this solution seems geared toward Plesk users) it would just be more convenient to use a different plug-in or write something myself. I hope you can find out the reason for the issue.

  20. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

  21. stonesleep
    Member
    Posted 1 year ago #

    Yes, version 3.03 of the plug-in is running on another one of my development sites and is operating just fine there.

  22. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

    Could you provide your php.ini settings?

  23. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

    Please try installing the development version and let me know if the issue has resolved: http://downloads.wordpress.org/plugin/social-media-widget.zip

  24. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

    Have either of you guys tested with the development version (link above)? I'm trying to have this patched up on the next update.

  25. stonesleep
    Member
    Posted 1 year ago #

    Let me give it a try, I've been afraid to test it out but I need to do some changes on one site in particular so I'll let you know how it turns out later today

  26. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

    Ok thanks. Please download again if you had before, since I've made a few more changes since then.

    http://downloads.wordpress.org/plugin/social-media-widget.zip

  27. kmg454
    Member
    Posted 1 year ago #

    We will try this coming week when we start a new test website

  28. stonesleep
    Member
    Posted 1 year ago #

    I downloaded the latest development version you posted, installed it, and immediately the site slows to a crawl.

  29. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

    Is it possible to provide a link to an active install?

  30. stonesleep
    Member
    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.