WordPress.org

Ready to get started?Download WordPress

Forums

WordPress site displaying blank (4 posts)

  1. mitchtheboss
    Member
    Posted 1 year ago #

    I am aware this has been posted before, I have also done many searches and tried many suggestions, all without any luck.

    My site was working on Friday, but, this morning when I checked it I had the White Page of Death. I have had this problem before and was able to locate a file that had been corrupted with "eval ([blah, blah]...)" and that fixed the error.

    Details:
    Site: Boldservices.com
    Wordpress Version: 3.5
    Theme: ZigZag WordPress theme (latest update put in this morning in attempt to repair)

    What I've done to attempt to repair:
    - I noticed that my wp-settings.php file had the "eval (..." script at the start so i removed that
    - I replaced all the standard WordPress files in my home directory (not wp-admin, wp-content, wp-includes) they are all fine and complete
    - I changed the name of the plugins folder and put the standard plugins folder in place.(no luck, so I changed it back)
    - I removed the theme I am using completely and tested again.(no luck, so I uploaded the most recent version of the theme)
    - I have attempted making a testing.php file consisting of

    <?
    ini_set('display_errors','1');
    ini_set('display_startup_errors','1');
    error_reporting (E_ALL);include('index.php');
    ?>

    (I could not navigate to this either.)
    - I called my hosting provider and they checked everything on their end and it all checks out so it's not their issue.
    - I am able to navigate to /info.php and /index.html

    Please if anyone can help me out with this it would be great!

    At this point clients and staff are all asking me what's happening, we need this back online!

  2. esmi
    Forum Moderator
    Posted 1 year ago #

  3. mitchtheboss
    Member
    Posted 1 year ago #

    Thanks esmi I'll go through these to try to get it sorted out.

  4. mitchtheboss
    Member
    Posted 1 year ago #

    I've gone through all of these.

    Via FTP I have completely replaced everything in my core WordPress files as well as wp-includes and wp-admin. I have gone through my wp-content folder and removed any unnecessary themes. I have updated the theme i was using. I have also gone through the plug ins and removed any im not using. removed some that I am using. and replaced any with the most up to date versions that I had added. I have tried all the security checks and I end up with one of 2 things. "Error 500" No page found, and everything else has checked that there is nothing malicious... So i don't know what it's doing right now...

    Anyone have any other resources or suggestions.

    *note: I am prepared to reinstall wordpress from scratch and re-create the site. But, I did not back it up prior to this corruption. I did back up the database yesterday (hopefully it isn't the cause of corruption) and I'm wondering if I import it into a fresh install of WP. will it maintain all the details... (ie. will it serve the same purpose as the "export" function in wordpress tools, since I can't access that page)

Topic Closed

This topic has been closed to new replies.

About this Topic