WordPress.org

Ready to get started?Download WordPress

Forums

WordPress site broken links (16 posts)

  1. thisislife
    Member
    Posted 2 years ago #

    Hi

    I am fairly new to wordpress.

    I have recently created a site, which i created in a subfolder (/wordpress). I have just moved the site over to the route folder, updated the site url back to my route directory, and run a searchandreplace to change the databases entries.

    The issue i have is, the site is working, well most of it (a few missing images), but the links to my pages include a hashtag, which tells me something is wrong with the linking of the pages.
    The link to the site is: http://cambridgehomes.co.nz once you click on the links at the top you will see exactly what i mean. For example, once clicked on 'the company' the link displays http://cambridgehomes.co.nz/#/the-company/ rather than http://cambridgehomes.co.nz/the-company/
    My permalinks are set up to show 'Post Name', so i do not believe that is the issue.

    I would be grateful for any help on this.

  2. thisislife
    Member
    Posted 2 years ago #

    I have also noticed my website header stays the same (Home - Cambridge Homes) on every page you click on. I don't know whether that might give someone an idea as to why the pages are hashed.

  3. thisislife
    Member
    Posted 2 years ago #

    Also if you type in the actual address of the page, it displays correctly, but once you click on a link it doesnt link correctly, for example:
    http://cambridgehomes.co.nz/the-company/ is the company page, which works perfectly, but once you click on our designs, the link links to http://cambridgehomes.co.nz/the-company/#/our-designs/

  4. Gaurav Raghav
    Member
    Posted 2 years ago #

    well i think you have left a space bar while moving the site . Check that out .

  5. thisislife
    Member
    Posted 2 years ago #

    Thanks for the quick response Gaurav.
    I have just checked that and i did have two '/' in my database, so it was reading http://cambridgehomes.co.nz//wp-admin....
    I have replaced that now, but it is still showing the same way. I have checked in my General Settings, and that is correctly linked. I have cleared my cache.

  6. Gaurav Raghav
    Member
    Posted 2 years ago #

    Have you checked your permalink structure . Try changing them . IT might work now.

  7. thisislife
    Member
    Posted 2 years ago #

    I have changed those, they are currently set to http://cambridgehomes.co.nz/sample-post/ i have changed them to Numeric and back, but still no luck

  8. thisislife
    Member
    Posted 2 years ago #

    When you hover over the links, the status bar displays them correctly, but it seems as though the hashtag is being forced into the link once its clicked.

  9. Gaurav Raghav
    Member
    Posted 2 years ago #

    Ok have one more try .
    Create a new page and see for it that your database is updating normally now .

  10. thisislife
    Member
    Posted 2 years ago #

    The pages in the database are showing up as http://cambridgehomes.co.nz/?page_id=43 for 'the-company' page, is that how they should be displayed in the database?

  11. Gaurav Raghav
    Member
    Posted 2 years ago #

    Yes , Now you create new pages for your all pages that are not working . Remove old ones and give the permalink to new ones like co.nz/company
    . They will work fine .

  12. Gaurav Raghav
    Member
    Posted 2 years ago #

    And use any permalink which you like

  13. thisislife
    Member
    Posted 2 years ago #

    Still doesnt work, i have recreated all the pages, but it still links through with the hashtag. Very confusing.

  14. Gaurav Raghav
    Member
    Posted 2 years ago #

    I think its error with some code because if you write click and open in new tab then it is working fine .

  15. thisislife
    Member
    Posted 2 years ago #

    Time to read through all the code again, fun times! Thanks for your help Gaurav!

  16. Gaurav Raghav
    Member
    Posted 2 years ago #

    Ok do it lets see what happen

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.