WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress Shows Not Found Page For A Query String with External Domain (5 posts)

  1. oneTarek
    Member
    Posted 1 year ago #

    Today I have discovered a strange issue on WordPress URL handling process. WordPress shows not found page if my URL has a query string containing an link of external domain. You can not pass any link of external domain through your permalink or static file URL. Test my following urls to be clear on the problem I am talking about.

    1. http://onetarek.com/wp-content/uploads/2012/11/wptinymce.jpg
    2. http://onetarek.com/wp-content/uploads/2012/11/wptinymce.jpg?myvar=sometext
    3. http://onetarek.com/wp-content/uploads/2012/11/wptinymce.jpg?myvar=http%3A%2F%2Fonetarek.com
    4. http://onetarek.com/wp-content/uploads/2012/11/wptinymce.jpg?myvar=http%3A%2F%2Fgoogle.com

    I wrote a blog post by describing this issue in detail with examples. If you don't understand the problem read my blog post about this WordPress Permalink Problem.

  2. oneTarek
    Member
    Posted 1 year ago #

    This Problem is not for all WordPress website. Some website return correct file, does not show not found page. My websites are hosted on HostGator server. Please help me, what is the wrong with my website or server?

  3. oneTarek
    Member
    Posted 1 year ago #

  4. M Asif Rahman
    Member
    Posted 1 year ago #

    If it even works for one site in HostGator then you cant say its their issue.

    Cause may be how server or specific site/folder handling error. Means it could be something related to .htaccess configuration.

    To test , how about test with a basic WP setting in a root domain, not in sub domain.

  5. oneTarek
    Member
    Posted 1 year ago #

    Finally my problem has been solved.
    I discussed with HostGator support. They told me that They run mod_security which is the cause of the problem. To solve my issue they ran a command to whitelist a mod_sec rule my site was hitting. You have to know detail about mod_security. If you have root control on the server, you could change it in php.ini

Topic Closed

This topic has been closed to new replies.

About this Topic