WordPress.org

Ready to get started?Download WordPress

Forums

WordPress should ignore plugins not compatible with version (3 posts)

  1. syncbox
    Member
    Posted 4 years ago #

    It seems to me that if a plugin developer cannot be bothered to make their plugin A) compatible with the latest version and B) work smoothly with the core update functions now in WordPress that WordPress should remove the plugin from the site's extend/plugins list. Conversely, it should REWARD those developers who DO put in the time and effort to keep their plugin tuned up. IMO, the plugins list should ONLY contain plugins that are compatible with the latest version, OR, at the very least, should allow filtering by WordPress version.

    And before anyone reminds me that plugins are free... contrary to the popular whine, plugin authors DO benefit from their "free" plugins -- they gain community expertise and stature that helps them in their profession, for the most part. For example, there are key SEO plugins developers who project themselves as experts and get work based on that, charging a fat rate for their services.

    Sure, there are pros and non-pros offering plugins and for that, I commend them. Heck, I often donate. KUDOs for a job well done and THANKS.

    But, if you don't plan to keep your work compatible with the latest version of WordPress, why bother at all? Particularly for SEO, because these folks KNOW the effort involved with it and the importance of not having to "start over" after a year or two of said effort just because a plugin's author finally landed a big job and can't be bothered anymore.

    Users are nagged on their plugins page after updates to the application -- that functionality is there for a reason -- and if you are going to keep offering your plugin, it needs to work with WordPress correctly and smoothly OR suffer a penalty by being dropped from the extend/plugins list...

    OK, rant over and thanks for listening. I'm not a plugin author but I AM and have been for YEARS, a beta tester of major commerical software and so I know the effort and processes. I don't whine that often about this, but feel occasionally that I have to make the point that developers DO profit even from FREE plugins and should be personally invested in delivering the best product they can OR JUST DON'T BOTHER AT ALL.

  2. Michael Torbert
    WordPress Virtuoso
    Posted 4 years ago #

    Most plugins don't actually break when a new version of WordPress comes out. Depending on what changes in WordPress, and what the plugin actually does, some can go months, years, or permanently without having to be actually updated.
    Some of us release a new version every time WordPress comes out with a new version, even if just to update the version number that it's supposedly compatible with. If a plugin developer doesn't do that, the plugin very possibly is still compatible with the latest version of WordPress.

    Also, just because a plugin developer says a plugin is compatible with the latest version doesn't make it so.

    Either way, the user always needs to ensure that the plugin will work with their particular version of WordPress, collection of other plugins, server configuration, etc.

    By the way, the fact that some developers of free plugins may receive benefits other than payment doesn't make them required to do anything. I have plenty of software that I've paid for that doesn't do everything I want it to do. People pay tons of money for Windows, Office, Photoshop, etc... all of which have users wanting more features, bugs fixed, etc.

  3. Michael Torbert
    WordPress Virtuoso
    Posted 4 years ago #

    Having said all that, I do agree that it would be nice to find another method of gathering the compatible version.
    At the moment, the plugin author just needs to enter it into one field. They can put whatever they want. This leads to plugins not having a high enough version (where people don't realize it's still working) as well as developers listing too high a version.

Topic Closed

This topic has been closed to new replies.

About this Topic