WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO Yoast plugin not working after permalink redirect (2 posts)

  1. Jessica
    Member
    Posted 1 year ago #

    Hi there,

    I installed and activated Yoast's WordPress SEO plugin last week. As I familiarized myself with it and read more about SEO, I decided to change my permalinks from the day and name structure /%year%/%monthnum%/%day%/%postname%/ to /%postname%/

    After I did that I couldn't access my homepage, even though I could access all other posts and pages. Of course, clicking on old links with the date included resulted in an error as they were in the old format and hadn't been redirected. I went through the process of doing a 301 redirect by adding a line of code to the .htaccess file in my File Manager within the cPanel.
    It currently looks like this:

    # Use PHP5 Single php.ini as default
    AddHandler application/x-httpd-php5s .php

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On

    RedirectMatch 301 ^/([0-9]{4})/([0-9]{2})/([0-9]{2})/(.*)$ http://notesofnomads.com/$4

    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    This worked to redirect links from the old posts and pages to the new permalink structure. However, I still couldn't view the homepage. It said:
    "Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

    I could see the dashboard though.

    The only thing that I have found to troubleshoot this problem is to deactivate Yoast's WordPress SEO plugin. I have tried setting it back to default settings and doing a fresh install of the plugin but every time I re-activate it, the problem comes back, and it deletes the extra code I added in the .htaccess file for the redirect, so I get those ugly permalinks again when I click on them (from old links on Facebook page etc) rather than redirecting me to the pretty ones.

    At the moment I have the plugin deactivated as I don't want my homepage to be inaccessible and I have re-added the 301 redirect code to the .htaccess file. However, I would really like to continue using the plugin. I was only just starting to work with its features and I think it would be a powerful tool.

    Can anyone shed any light as to how the plugin might be interfering with the redirect or if there is any other fix for this?

    My site is: http://notesofnomads.com

    Many thanks in advance,

    Jessica

  2. livealone
    Member
    Posted 1 year ago #

    Hi Jessica,
    You have to unchecked "Redirect ugly URL's to clean permalinks. (Not recommended in many cases!)" option in Yoast WordPress SEO: Permalink Settings.

    People make mistakes in their links towards you sometimes, or unwanted parameters are added to the end of your URLs, this allows you to redirect them all away. Please note that while this is a feature that is actively maintained, it is known to break several plugins, and should for that reason be the first feature you disable when you encounter issues after installing this plugin.

    Hope it'll work for you.

    [link deleted - please do no use these forums to post links to your site ]

Topic Closed

This topic has been closed to new replies.

About this Topic