WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
WordPress SEO plugin not saving title, description & keywords on Pages (10 posts)

  1. msalmanzaib
    Member
    Posted 1 year ago #

    WordPress Version : 3.5
    WordPress SEO Plugin : 1.3.4.1

    SEO by Yoast plugin settings are not saving on Pages while working on posts. I tried to save settings on many pages many times but its not saving keywords, title description. yesterday, It was working fine. I have not installed any plugin within this time. don't know why this occur. Website : http://www.seodigital.org

    Thanks looking for a fast solution.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. maxonlinemarketing
    Member
    Posted 1 year ago #

    WordPress Version : 3.5
    WordPress SEO Plugin : 1.3.4.1

    I have the same problem (the only difference is that I've just installed a new theme). Website: http://www.maxonlinemarketing.co.uk

  3. msalmanzaib
    Member
    Posted 1 year ago #

    Issue fixed in new update yoast seo plguin 1.3.4.4

    Thanks,

    http://www.GigsTask.Com

  4. maxonlinemarketing
    Member
    Posted 1 year ago #

    It didn't solved my problem. I still have the same problem :(

  5. iskazi
    Member
    Posted 1 year ago #

    WordPress SEO Version 1.3.4.4
    WordPress 3.5.

    I'm having the same problem. SEO settings are not saving on pages.

    http://www.mybodytemple.com

  6. sugoo
    Member
    Posted 1 year ago #

    I'm having the same problem. SEO settings are not saving on pages.

    WordPress 3.5.1
    WordPress SEO Version 1.4.2

  7. jbishop60
    Member
    Posted 1 year ago #

    Hi, Just tested Pages and Posts, and i'm getting exactly this issue also. I raised it in a seperate post a few months back.

    Wp 3.5
    SEO 1.4.2

    Posts appear to save all the appropriate data so when you return to the page, the information is still in the fields. The Page Titles etc all pull through on to the site.

    Pages however seem to have an issue, although when completing the SEO title and metadata and saving, the data is saved to the site pages and you can see the data in the appropriate columns in the Page list, but the fields empty of the information when you go back into the page. (they are actually empty stright after saving)

    Am i making any sense! :)

    I run multiple installations of wordpress with the SEO plugin, and this issue occurs on more than one of them. All sites are with the same host all using the same theme.

    This particualr installation is 3.5 I'm hesistant to upgrade to 3.5.1 as the site has only just gone live and i cant afford for any major issues right now.

    Although the SEO data seems to be making into the site, the plugin is not working fully as i think it was intended, at least not at the Page level.

    Would love to get a resolution to this but i appreciate that with such a popular plugin, support is probably taking up quite a bit of your time!!

    thanks in advance

    J

  8. iskazi
    Member
    Posted 1 year ago #

    Thanks jbishop60.
    Although I would like the plugin to work as advertised, it helps to know that the data is saved to the site pages. I did a Google search of my keywords and it confirmed your statement.

    Thanks again.

  9. jbishop60
    Member
    Posted 1 year ago #

    but be careful as when you go into edit a page later on, when you hit update, the seo data will essentially be wiped, at least is has been in my experience.

    Its happenig all over th place. The only installation configuration that seems to be ok is WP 3.4.2 with SEO 1.4.3

    I've upgraded several installations to tbe most recent version of both WP and SEO, with no fix on the page metadata retention issue.

    Really would have hoped Yoast to have picked it up before moving to email only support. But then, it is free, so hey!......If i see it in future, fresh installations, i'm either going to have cough up or look at an alternative SEO plugin. :(

    J

  10. jbishop60
    Member
    Posted 1 year ago #

    SOLUTION FOUND!! Courtesy of Whoathemes

    So so simple!! I fixed this issue, across several different sites, by simply dragging and dropping the gallery box below the Yoast SEO box on the page edit view.

    I don't know why, but having active galleries and where the gallery box was above the SEO box caused SEO data not to be saved against the page.

    Phew! I can now continue to enjoy the benefits of Yoast with confidence. Was getting a bit frustrated with not being able to get anything back form Yoast though. buts its free, so hey, cant complain too much!! :)

    Just glad i found a solution, hopefully it helps someone else.

    James

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic