WordPress.org

Ready to get started?Download WordPress

Forums

[Wordpress SEO Plugin] Google pulling up wrong titles all of a sudden (2 posts)

  1. sparklogix
    Member
    Posted 2 years ago #

    We recently revamped our entire site, which included changes to a lot of pages, as well as additions. During the process, we also changed a lot of the SEO titles. While the new theme was being built, we had it on a completely different domain. While it was there, it had the wrong site title (missing an "S"). We fixed it, transferred the theme & database to the correct domain, checked everything in Google, monitor it regularly, no problems.

    Now, all of a sudden, some of our pages are missing SEO information altogether, pages that had complete SEO titles, keywords, etc. The Site Title also reverted back to the wrong one (missing the "S"). We have not made any changes in regards to theme files or plugins. Simply adding and editing pages. We have not even looked at the Settings page. Even though the homepage has the Yoast plugin info filled out correctly, Google results show the wrong site title, rather than the current SEO title for that page. This seems to be a random occurrence in Google, because some pages have the right titles and some do not.

    Why would these titles stop working all of a sudden?

  2. avjoseph
    Member
    Posted 2 years ago #

    Is it that some pages have the correct title and some do not, or is it that Google is caching 2 different copies for each page/post. <- I ran into this problem. Search for exactly what the correct titles would be for a particular url and then search for what the incorrect title would be for the url or possibly the url itself

Topic Closed

This topic has been closed to new replies.

About this Topic