WordPress.org

Ready to get started?Download WordPress

Forums

wordpress rewrite/permalink bug (3 posts)

  1. e-head
    Member
    Posted 9 years ago #

    index.php?author_name=<whatever> doesn't work.

    I call this a bug because the rewrite rules wp dumps for you when enabling permalinks use this query string, which doesn't seem to work for me.

    index.php?author=<id> works just fine, btw, but is not ideal because it requires the ID and not the author name.

    I could be doing something wrong.
    Any ideas ?

  2. Kafkaesqui

    Posted 9 years ago #

    Seems to be working for me. There's a solution to a different problem when using custom permalinks and .htaccess; you may want to see if it deals with yours:

    http://wordpress.org/support/topic.php?id=24402

  3. e-head
    Member
    Posted 9 years ago #

    I finally figured this out. Thought I'd pass this along in case anyone is interested.

    I've never really used the "Firstname", "Lastname" fields. My users have always just left these blank. I think I was expecting the author_name=<> to use the login name, but of course it uses the Firstname.

    On wp 1.2 (my version) changing the Firstname later doesn't seem to help, so you have to give firstnames when the user is created I guess. My version is a bit hacked though so I don't know if this is the norm.

    On wp 1.5 adding a Firstname later seems to fix things up just fine.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.