WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Requirements Page needs to be updated. (8 posts)

  1. SpontaneousOrder
    Member
    Posted 6 years ago #

    On the requirements page at http://wordpress.org/about/requirements/ it says "PHP version 4.2 or greater." This is no longer true for the new 2.3 release. I believe that php 5 is required (the code uses stripos, which is a php 5-only function according to php docs).

    I'm glad I backed up my files before installing 2.3! It would have saved a newbie some time if that requirements page had been correct.

    By the way, this window I am now typing in to make this post asks "What version of WordPress are you using?" and does not offer "2.3" as a choice.

  2. Jeremy Clark
    Moderator
    Posted 6 years ago #

    works perfect for me with php 4.4.7.

  3. MichaelH
    Member
    Posted 6 years ago #

    No, 4.2 is the correct minimum PHP level.

    The developers put a version of the stripos function in wp-includes/compat.php

  4. SpontaneousOrder
    Member
    Posted 6 years ago #

    Jeremy: I don't understand why it's working for you. I also have php 4.4.7, but WordPress 2.3 fails with "no such function stripos" in wp-includes/query.php. The php manual at php.net/manual/fi/function.stripos.php says that stripos is supported only in PHP 5. That's why I believe that php 5 is required for WordPress 2.3.

  5. SpontaneousOrder
    Member
    Posted 6 years ago #

    Thanks Michael: I see the compat.php and it does define stripos, but I nevertheless get the "no such function" error. I suppose it's not getting executed in time, but I don't know why.

    One theory is that I was trying to use the "maintenance mode" plug-in to put up that nice "come back in an hour" screen while I was updating - I saw that suggested somewhere and that people were successfully using that while upgrading to 2.3. I suppose I'll try again with that turned off and see if that was the problem.

  6. Jeremy Clark
    Moderator
    Posted 6 years ago #

    I have multiple blogs running 2.3 as well as the latest trunk all under 4.4.7. As michael pointed out if you look in wp-includes/compat.php you'll see the function included at the bottom.

    What exactly are you doing when you see the error.

    Perhaps you have a plugin that is stubborn about the php version. Try disabling some and keep trying.

  7. SpontaneousOrder
    Member
    Posted 6 years ago #

    When I deactivated the "maintenance mode" plug-in, release 2.3 installed fine for me. Thanks for all your help.

    So, even though the page for the plug-in says it is compatible with 2.3, I guess that it won't work while upgrading to 2.3 unless a newer version of php is installed than what I have.

  8. Bull3t
    Member
    Posted 6 years ago #

    It isn't really a good idea to keep plugins enabled while updating (for smaller scale updates it's fine (such as version 2.3 to 2.3.1, for example) but it's really not a good idea otherwise.

    It shouldn't affect it, but most of the time it is good to disable all plugins while updating to larger scale version of WordPress.

    That error was a little odd though, I have to admit.

Topic Closed

This topic has been closed to new replies.

About this Topic