WordPress.org

Ready to get started?Download WordPress

Forums

WordPress + ProPlayer + bbPress = XML ? (8 posts)

  1. ced64k
    Member
    Posted 5 years ago #

    Hi,

    I have WordPress 2.8 and bbPress 1.0 RC3 inside the “forum” folder. With deep integration (mysql, cookie, header, etc). When ProPlayer is actived in WordPress, if I try to access to any bbPress forum page, I have only a xml file :

    <?xml version='1.0' encoding='utf-8'?>
    <playlist xmlns='http://xspf.org/ns/0/' version='1'>
    	<trackList>
    		<track>
    			<location>/forum/forum.php</location>
    			<meta rel='type'>image</meta>
    			<image>/forum/forum.php</image>
    		</track>
    	</trackList>
    </playlist>

    Any idea ?

  2. isa.goksu
    Member
    Posted 5 years ago #

    @ced64k, first off all I've never tried this combination. So my answer might not be accurate. However, I do think somehow something is invoking the playlist-controller.php file. Without seeing your code base it's very hard to tell anything. If you can send me some test URL I can look at it.

    Best,
    Isa

  3. ced64k
    Member
    Posted 5 years ago #

    I make further investigation. It's not caused by bbPress. Every url like this return a xml playlist file when ProPlayer is active:

    http://mysite.com/anyfolder/?id=anyvalue
    http://mysite.com/anyfolder/otherfolder/?id=anyvalue

    I also tried with or without permalinks.

    Thanks.

  4. ced64k
    Member
    Posted 5 years ago #

    I found the same bug on another site using ProPlayer :

    http://17film.info/blablablabla/?id=blablablabla

    So the problem is here ?

    if (!empty($_GET["id"])) {
       header("Content-type: application/xml");
       $xml = $playlistController->getPlaylist($_GET["id"]);
  5. ced64k
    Member
    Posted 5 years ago #

    Quick and dirty fix:

    playlist-controller.php (line 150). I remplaced this :

    if (!empty($_GET["id"])) {

    with :

    if (!empty($_GET["id"]) && !strpos($_SERVER['REQUEST_URI'],'forum') === true) {

    Waiting for a better solution ;-)

  6. isa.goksu
    Member
    Posted 5 years ago #

    @ced64k, that's really interesting. I still don't get why playlist-controller.php is being invoked :S

    I'll look at that in ASAP and will let u know.

  7. ced64k
    Member
    Posted 5 years ago #

    @isa.goksu, it seems solved with the v4.5.1, thanks :)

  8. isa.goksu
    Member
    Posted 5 years ago #

    @ced64k, yeah I know. After your warning, I've fixed that :)

    10x for letting me know.

    Best,
    Isa

Topic Closed

This topic has been closed to new replies.

About this Topic