WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Photolog New Version (79 posts)

  1. Laughinglizard
    Member
    Posted 10 years ago #

    Kathie: it looks like you dont have GD installed on your server. Try changing the $usePBM value in wp-admin/post.php (towards the top of the file)

  2. faewench
    Member
    Posted 10 years ago #

    LL thanks for the correction/addition to the edit page postings:))) that is a big plus!
    fae

  3. ara
    Member
    Posted 10 years ago #

    I have a couple of questions:
    If you were to go to index.php?p=1 the comments link does not show up, but if you were to go to index.php?cat=1?paged=3 the comments link shows up fine. Do you know why this is?
    Is there a way to list the thumbnails when you click into a category link? Because it would be nice if you didn't have to click the next button so many times just to find a picture.

  4. Kathie
    Member
    Posted 10 years ago #

    Actually I installed it again. I just wanted to make sure I didnt forget one step.
    Now I dont get an error, but whenever I click on post I get a blank page. I dont understand why :(
    And this is the url I get... http://close--up.net/pictorialis/wp-admin/post.php

  5. Laughinglizard
    Member
    Posted 10 years ago #

    @ara: when the comment form is displayed, the comment link is not displayed and vice versa. That is by design. With the cat=1&paged=3, everything gets overridden and you see everything available on that page. Is that what you were asking?
    At this time there is not category hack. You could download the archives from the previous thread which lists pictures by category. I might come up with a category browsing solution sometime later if there is enough interest.
    @Kathie: If you dont have GD installed and changing the $usePBM value gives you a blank page, you do not have that installed either. The error from NetPBM is not as graceful as from GD and all you end up with is a blank page. You should contact your webhsot to see if they could install either GD or NetPBM on your server.

  6. Kathie
    Member
    Posted 10 years ago #

    Oh. I wouldnt be able to install that myself, no?

  7. Laughinglizard
    Member
    Posted 10 years ago #

    @Kathie: only if you are your own webhost. You could download the NetPBM binaries from the gallery distribution and then modify the paths in post.php, but its not a simple install by any means.

  8. Kathie
    Member
    Posted 10 years ago #

    That sucks. My main domain is hosted at Netrillium and I know for fact they have both.
    However, the one I want to install this at is hosted at my friend's reseller which she got from pinchpenny. They arent really reliable though and even closed their site for the timebeing. Now I really dont know who to ask for this. I could ask my friend, but she doesnt really know much about all of this stuff.

  9. Laughinglizard
    Member
    Posted 10 years ago #

    Sorry :(
    I might be able to come up with a solution for you. But I cannot give you an ETA for it at this time.

  10. aletheia
    Member
    Posted 10 years ago #

    Hi LL, great work with Pictorialis...
    I'm thinking of using it in a project I'm developing. I think I saw a comment about this in another thread but I can't find it now.
    I need to know if I can use pictorialis for a section of the web and not as the main blog. If I install it in a directory such as /pictorialis, using the same database as the wp blog, do I need to create new tables or anything?
    Thanks..

  11. Laughinglizard
    Member
    Posted 10 years ago #

    @alethia: you dont need to create a new database as long as you are willing to put up with a few nuisances till things get worked out. In other words, things might break a little and you will have to give me the chance to fix them as and when they arise.
    :-)

  12. subconcious
    Member
    Posted 10 years ago #

    Hi
    I just installed Pictorialis this afternoon. I'm really happy to finally have something that looks and functions like a real photoblog after spending a lot of time mucking with other things and trying to adapt them.
    Anyway, I had been running Nucleus, but in an absence of forward thinking, deleted that whole directory after I had WP running. I don't think there is a Nucleus import tool anyway, so it isn't a huge deal.
    I was going to manually throw in all my posts in 2004 by posting them, and then editing them to back date them as appropriate. When I go to the archive however, it shows them as being May 2004, instead of Jan 2004. It would appear that the backdating isn't functioning.
    I feel like I'm missing something really obvious, and if I am sorry, but could someone give me a shove in the right direction?

  13. w8in
    Member
    Posted 10 years ago #

    Great work, LaughingLizard !
    I have one problem though : if I click on a photo to see the larger version, it can't find it (I noticed that the file doesn't go to /upload, but to /wp-admin/upload)
    http://www.w8in.com/wppic
    What could cause this?

  14. Laughinglizard
    Member
    Posted 10 years ago #

    @w8in: looking into it

  15. urbanamy
    Member
    Posted 10 years ago #

    Do I need to have GD installed by the web host co.? That'd explain the blank page. Grr. :)

  16. aletheia
    Member
    Posted 10 years ago #

    Heeey! Just installed pictorialis and it looks good :-)
    Just a couple of issues to start with.
    I was wondering if you thought of implementing an option for thumbnail creation with ImageMagick. GD is alright for a start, but the quality is too poor even at 100 quality.
    Another thing I've noticed is that you give a max size for the sizes of the pictures. What that actually does is it gives the image that size, so if it's smaller it stretches it to that size viceversa if it's larger. That makes the picture all ugly, specially if you haver regular photos that usually have wider widths when horizontal. My solution at the moment is creating a category for horizontal and another category for vertical and creating the pictures with the same size given in the post.php
    Meanwhile, since the quality of compression is not convincing, I'm uploading the images myself hoping for a better version later on.
    When duing this I also noticed that the images I uploaded, when originally only they where about 40 kb, they turned to 100% quality jpg files of about 220kb. That's not nice, specially when I compressed it to look good at a low weight and then they look worse at a higher quality ;-)
    Lastly, when you click on the large picture, it gives me an error which I don't understand because the url is pointing to the jpg image (no php)...
    I'm about to embarc on the design issue and my firs question is how can I show on my first page all the thumbnails of one category?
    Anyway, thanks and good work. I can see it's a big deal you are taking up here LL, I'll post anything I come up with tinkering on my own.

  17. aletheia
    Member
    Posted 10 years ago #

    almost forgot, it's not parsing latin characters right, I mean, letters like áóíúé ñ are not showing correctly. Something I haven't configured right?

  18. yodaamidala
    Member
    Posted 10 years ago #

    for some reason, i cant seem to configure it..

  19. yodaamidala
    Member
    Posted 10 years ago #

    I always get this:
    Warning: move_uploaded_file(): open_basedir restriction in effect. File(/public_html/photoblog/upload/051904bangkok.jpg) is not within the allowed path(s): (/***/:/usr/lib/php:/usr/local/lib/php:/tmp) in /****/photoblog/wp-admin/post.php on line 191
    Warning: Cannot modify header information - headers already sent by (output started at /****/public_html/photoblog/wp-admin/post.php:191) in /****/public_html/photoblog/wp-admin/post.php on line 345

  20. Laughinglizard
    Member
    Posted 10 years ago #

    @urbanamy: This hack can also use ImageMagik. The readme has a little more information on how to switch between GD and ImageMagik.
    @alethia: As above, ImageMagik is already an option in Pictorialis. The readme makes things a little more clear. Most of the quality issues can be resolved by switching to ImageMagik. As for the upload folder issue, there was an error in the readme which has been resolved in the new download. I suggest that you download the zip file again and go through the readme one more time. :-)
    @yodaamidala: Are the permission for the upload directory set correctly? Try 777 .

  21. yodaamidala
    Member
    Posted 10 years ago #

    Yes, I've set the permission to 777 and even post.php.

  22. urbanamy
    Member
    Posted 10 years ago #

    I tried to use the upload pic and the pic doesn't show up at all. Just the text, but not the image itself. I made sure all 3 folders are within wp-admin folder and chmoded to 777. I'm not sure what is missing. I got no error message so far. I'm using GD which is enabled on the server. I don't see ImageMagick in readme. I did d/l the zip recently but nothing in there. What's the solution? Thanks. I look forward when it does work.

  23. dss
    Member
    Posted 10 years ago #

    oh my...
    so let's pretend i already have WP installed and working like i'd like it to...
    if i wanted to add this as domain/blog/photo
    how would i do that?
    scrap what i have, install yours and then try to make it look and work correctly?
    or is there another way?
    oh my...
    dss

  24. Anonymous
    Unregistered
    Posted 10 years ago #

    please help, i got this
    Fatal error: Cannot redeclare touch_time() (previously declared in /home/shuji/public_html/photoblog/wp-includes/functions.php:451) in /home/shuji/public_html/photoblog/wp-admin/admin-functions.php on line 328
    what the heck? its a new wordpress and photolog install

  25. Anonymous
    Unregistered
    Posted 10 years ago #

    ah..nevermind that, i got it to work now, stupid ftp didnt overwrite my files :P
    thx alot

  26. aletheia
    Member
    Posted 10 years ago #

    Hi LL,
    I downloaded the latest version (my guess) from the link you have on the first post of this thread but I find nothing different from my previous version. The zip is pictorialis-2.
    I can't find nothing about Image Magick you only mention NetPBM (unless that's the same thing?)
    thanks :-)

  27. w8in
    Member
    Posted 10 years ago #

    dss, you can install pictorialis in a totally separate folder. Yet, you can use the same MySQL database.
    In the wp-config, you'll have to change the prefix :
    From wp-config.php.sample:
    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'

  28. urbanamy
    Member
    Posted 10 years ago #

    I still can't publish uploaded photo. I'm not sure what's happening here. I followed ReadMe again and made sure the dirs are in the right places (images and thumbnails in WP admin folder, upload in root dir). I even made sure GD is enabled as well. I set up a different mySQL db for this. Yet it wouldn't show the uploaded image or thumbnail at all. I wonder what could be wrong? Thanks.

  29. Anonymous
    Unregistered
    Posted 10 years ago #

    is the latest version based on a nightly or on the Mingus release?

  30. etilena
    Member
    Posted 10 years ago #

    Hi, I just installed Pictorialis and the pictures are uploaded and all, but I get these errors on the Write page in admin.
    Warning: open_basedir restriction in effect. File is in wrong directory in /usr/local/psa/home/vhosts/makumaro.net/httpdocs/photos/exifer/exif.php on line 115
    Warning: open_basedir restriction in effect. File is in wrong directory in /usr/local/psa/home/vhosts/makumaro.net/httpdocs/photos/exifer/exif.php on line 116
    Warning: open_basedir restriction in effect. File is in wrong directory in /usr/local/psa/home/vhosts/makumaro.net/httpdocs/photos/exifer/exif.php on line 117
    Warning: open_basedir restriction in effect. File is in wrong directory in /usr/local/psa/home/vhosts/makumaro.net/httpdocs/photos/exifer/exif.php on line 118
    Warning: open_basedir restriction in effect. File is in wrong directory in /usr/local/psa/home/vhosts/makumaro.net/httpdocs/photos/exifer/exif.php on line 119
    Warning: open_basedir restriction in effect. File is in wrong directory in /usr/local/psa/home/vhosts/makumaro.net/httpdocs/photos/exifer/exif.php on line 120
    WordPress
    Can anyone help me?

Topic Closed

This topic has been closed to new replies.

About this Topic