WordPress.org

Ready to get started?Download WordPress

Forums

WordPress permalinks and database issue (2 posts)

  1. lemd
    Member
    Posted 1 year ago #

    Ok so I'm trying to change the permalink structure on wordpress to custom but everytime I save and refresh the page it defaults to "Post name". I've scoured the net for the past 2-3 hours trying everything and nothing is helping.

    The WP site is on Media Temple GS hosting. This site was migrated from a local build, not sure if that will affect it.

    Here are the things I've tried:

    Setting .htaccess in my blog main dir to 777 and saving from WP
    Deleting .htaccess and resaving permalink setting
    Clearing .htaccess and resaving permalink setting
    Manually going into the database and manually setting permalink_structure (just resets to /%postname%/ after refresh)
    Making sure 'Options +FollowSymlinks' and 'RewriteEngine on' are in htaccess (according to MT this is correct for their server according to their knowledgebase to allow mod_rewrite)
    Various .htaccess settings
    Searching for other possible .htaccess files that may be conflicting with the one in the root dir
    Changing the id number for permalink_structure in the database
    I'm out of options now so please dont just say to search the net. Any help is greatly appreciated!

    The fact that I can't even manually change it in the DB and have it save is the first red flag to me.

  2. Cyber735
    Member
    Posted 1 year ago #

    Maybe try Dean's Permalinks Migration?

    Keep me posted, as I'll be migrating my site from a local build soon too!...and I'm hoping this should fix any problems.

    Good luck,

Topic Closed

This topic has been closed to new replies.

About this Topic