WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress only has a blank page (32 posts)

  1. KaRaT92
    Member
    Posted 5 years ago #

    I've just installed wordpress on my webspace. I configure it a little bit and wrote a post and when I wanted to watch it, I only saw a blank page. If I try to visit my site, there's only a blank page. I only can visit /wp-admin/index.php and the admin menu. I don't know if I have forgotten to set rights a configure something.

    Link

    I really need help!

    Edit: I got this error message all the time.

    Fatal error: Call to undefined function file_exists() in /var/www/user21/html/wp-load.php on line 24

  2. stvwlf
    Member
    Posted 5 years ago #

    Hi

    You may not have uploaded all of the WordPress files when you installed WP. to keep things simple, try uploading WordPress again - you can overwrite what is already there. See if that clears the problem up.

  3. bradybarrows
    Member
    Posted 5 years ago #

    I am having the same problem. I uploaded all the word press files again. Cleared the tables in the database and tried again. I get the admin control panel so I know that word press installed. However, when I go to the site it is a blank page. I have been reading in this forum everything about this and can't figure it out. I have installed three word press blogs before with no problems but this one is giving me this one. What am I doing wrong?

  4. Ronnie
    Member
    Posted 5 years ago #

    i too have just installed wordpress.. I can see the admnin panel okay but the blog shows up as a blank white page

    please help

  5. Samuel B
    moderator
    Posted 5 years ago #

    blank pages are usually indicative of php errors or low php memory

    try bumping php memory to 32M
    turn on php error reporting to see what is breaking

  6. stvwlf
    Member
    Posted 5 years ago #

    try resetting your theme to the default theme. Even if it already IS set to the default theme.

  7. Ronnie
    Member
    Posted 5 years ago #

    thanks

    its on hosted server, which i believe is failry capable and robust
    i'm unsure how to turn on php error reporting

    i tried changing/resetting the themke but no joy

    http://www.ronniesblog.com

  8. Ronnie
    Member
    Posted 5 years ago #

    when i "view source" code on the blank page i get only the following:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>Ronnies Blog</title>
    </head>

    <body>
    </body>
    </html>

  9. stvwlf
    Member
    Posted 5 years ago #

    Ronnie, what is the URL that is producing that view source?

    It looks like that might be a dummy index.html file in your root folder that is preventing WordPress from running - if it exists Apache will serve up that dummy file and not go looking for WordPress

  10. Samuel B
    moderator
    Posted 5 years ago #

    @ stvwlf
    I don't think that is the problem or you could put index.php on the end of his url and wordpress should come up
    still say it's a php issue

  11. Ronnie
    Member
    Posted 5 years ago #

    not sure about the origin of the index file... its a prevailing index file.. which i believe was already there before i FTP'd up the wordpress files.

    should I ditch it?

    what file should the blog be running from?
    should the "view site" link from within the admin panel not be redirecting to the correct file?

    i'm going to go have a look

    thanks for your help

  12. Ronnie
    Member
    Posted 5 years ago #

    maybe i should remove this index file and re-install wordpress?

  13. Samuel B
    moderator
    Posted 5 years ago #

    wordpress uses index.php - it must be there
    if there is an index.html it will take precedence and must be eliminated
    however, that is not your problem - so good luck

  14. stvwlf
    Member
    Posted 5 years ago #

    Ronnie

    Contact your webhost and ask how you change settings to give PHP 32mb of memory as Samboll is suggesting. That would be the next thing to do.

    In terms of PHP error reporting, look in the root folder of your WP install and see if there is an error_log file. if so see what errors are occurring.

  15. Ronnie
    Member
    Posted 5 years ago #

    I did the deletion of index.htm and reinstalled... still the same.

    I have an admin control panel on my server and theres an apache error log there which displays the following:

    [Thu Apr 23 13:25:23 2009] [error] [client 217.16.216.157] File does not exist: /home/ronniesblog/public_html/favicon.ico
    [Thu Apr 23 13:25:26 2009] [error] [client 217.16.216.157] File does not exist: /home/ronniesblog/public_html/favicon.ico
    [Thu Apr 23 13:26:50 2009] [error] [client 217.16.216.157] File does not exist: /home/ronniesblog/public_html/favicon.ico
    [Thu Apr 23 13:26:53 2009] [error] [client 217.16.216.157] File does not exist: /home/ronniesblog/public_html/favicon.ico
    [Thu Apr 23 13:29:33 2009] [error] [client 217.16.216.157] File does not exist: /home/ronniesblog/public_html/index
    [Thu Apr 23 13:33:39 2009] [error] [client 217.16.216.157] File does not exist: /home/ronniesblog/public_html/ronniesblog
    [Thu Apr 23 13:33:44 2009] [error] [client 217.16.216.157] File does not exist: /home/ronniesblog/public_html/public_html
    [Thu Apr 23 13:33:50 2009] [error] [client 217.16.216.157] File does not exist: /home/ronniesblog/public_html/index
    [Thu Apr 23 13:59:54 2009] [error] [client 66.141.177.53] File does not exist: /home/ronniesblog/public_html/favicon.ico
    [Thu Apr 23 13:59:58 2009] [error] [client 66.141.177.53] File does not exist: /home/ronniesblog/public_html/favicon.ico
    [Thu Apr 23 14:00:06 2009] [error] [client 66.141.177.53] Directory index forbidden by Options directive: /home/ronniesblog/public_html/wp-content/themes/
    [Thu Apr 23 14:00:19 2009] [error] [client 66.141.177.53] File does not exist: /home/ronniesblog/public_html/favicon.ico
    [Thu Apr 23 14:00:21 2009] [error] [client 66.141.177.53] File does not exist: /home/ronniesblog/public_html/favicon.ico
    [Thu Apr 23 14:46:38 2009] [error] [client 66.141.177.53] File does not exist: /home/ronniesblog/public_html/index.html

  16. Ronnie
    Member
    Posted 5 years ago #

    what do you think?

  17. stvwlf
    Member
    Posted 5 years ago #

    It sounds like your files may be in the wrong place. It is also possible, as Samboll was saying, that not enough memory could be causing certain other PHP errors to occur. So next, get your PHP memory set to 32 megs. If you still have a problem after that, will investigate further.

  18. Samuel B
    moderator
    Posted 5 years ago #

    It sounds like your files may be in the wrong place.

    after seeing that I agree with stvwlf - you must not be in root

  19. Ronnie
    Member
    Posted 5 years ago #

    ok thanks
    contacted the host, will see what he says

  20. Ronnie
    Member
    Posted 5 years ago #

    didn;'t see your post samboll

    my wordpress files are in the public_html directory..... would this be correct?

  21. stvwlf
    Member
    Posted 5 years ago #

    I am now seeing your blog at http://ronniesblog.com/ with the default theme

  22. Samuel B
    moderator
    Posted 5 years ago #

    public_html directory

    correct

    edit - I see site now also - what up?

  23. Ronnie
    Member
    Posted 5 years ago #

    there it is yep... nice

    i reckon my hosty has been on the case..... will see what he feeds back with

  24. Ronnie
    Member
    Posted 5 years ago #

    it must have been the 32mb thing as thats the last thing mentioned to him

    thanks a lot for your help guys, sincerely appreciated.

    Ronnie

  25. wrightj999
    Member
    Posted 5 years ago #

    Samboll, when you can get the chance could you look at my post? I'm having a similar problem, except I just can't get into the wp-admin, but I can view the blog at it's URL.
    Here is a link to my post:
    http://wordpress.org/support/topic/264629?replies=1

  26. bradybarrows
    Member
    Posted 5 years ago #

    Please now help me. I still have a blank page. Here is the php info:

    http://lilliangrayphotography.com/info.php

    I can log into the admin control panel. It doesn't make any sense to me that I get a blank page. I have uploaded word press twice. I cleared the tables. Both times I can get the admin control panel. Both times I get a blank page for the site. What else can I do?

  27. bradybarrows
    Member
    Posted 5 years ago #

    I put the wordpress files in the root directory and want index.php to be the main page. Everything is in the same folder.

  28. stvwlf
    Member
    Posted 5 years ago #

    Brady

    After seeing the solution to this morning's issue it is likely yours is the same. Contact tech support at your webhost. Tell them you need 32 megs of PHP memory and how do you set that up on your hosting account. Ask them if they will configure that for you.

    That may resolve your whole problem. If not, after that change, post back here what is going on

  29. bradybarrows
    Member
    Posted 5 years ago #

    I called 1&1 and the tech said that the current server I am using is set to 20 megs of PHP Memory and can't be changed. What is weird is that I have three other Word Press Blogs on 1&1 that work fine and each one is version 2.7.1. This doesn't make any sense. Is there a work around for this or am I stuck?

  30. stvwlf
    Member
    Posted 5 years ago #

    Brady

    1)

    I put the wordpress files in the root directory and want index.php to be the main page. Everything is in the same folder.

    When several changes have occurred, we have to debug one change at a time, to find out which one is causing the problem.
    Did the blank screen problem exist BEFORE you did this? If the problem started when you made that change, reverse what you did - put it back as it was and see if it now runs correctly. If you made changes to the blog locations in settings, reverse those also back to the way they were. Admin / Settings / General

    If the problem existed before you made that change, or reversing it back did not resolve the problem, temporarily set your theme to the default theme and see if that makes a difference. If it works OK with the default theme, then try switching back to the theme you want to use and see if that works. Which of these steps work and which don't mean something as far as debugging what is going wrong, so please try them all and report back on what you found.

    If none of these work, the problem may be the RAM. Googling, I found 1and1 does not allow PHP more than 20megs of memory, so if that proves to be the problem, then yes you have a problem hosting with 1and1. However, its not yet determined that memory issue is the problem. It would have been nice to be able to bump it up, to eliminate that or prove it is the problem. But there are other things to test first before deciding memory is the culprit.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags