WordPress.org

Ready to get started?Download WordPress

Forums

WordPress on local WAMP - no admin priveleges (11 posts)

  1. SRD75
    Member
    Posted 1 year ago #

    I've installed WordPress 3.4.2 on WAMP on a Windows XP SP3 PC.

    WordPress is running fine, except for the fact my administrator account has no admin privileges. For instance, I can't add new plugins, can't administer user accounts, and can't perform updates to the core.

    The wp_capabilities of my user account is a:1:{s:13:"administrator";b:1;}

    The wp_user_level is 10

    Apache is running as the System user account, and this account has read/write access to my WordPress directory.

    Why is this happening? Thanks.

  2. ClaytonJames
    Member
    Posted 1 year ago #

    For instance, I can't add new plugins, can't administer user accounts, and can't perform updates to the core.

    Do you mean attempting any of those actions fails, or do you mean you do not have access to any of those options from the dashboard?

  3. SRD75
    Member
    Posted 1 year ago #

    Apologies, I receive the error: "You do not have sufficient permissions to access this page."

  4. ClaytonJames
    Member
    Posted 1 year ago #

    XP is generally so permissive by default in single user/administrative account mode, that I don't recall seeing many issues with actual machine user account permissions. A couple of things you could check first, silly as they might sound:

    1) Clear your browsers cache completely; cookies, cache, everything.. and see if the symptom changes

    2) Confirm your local account on Windows XP is running with administrative credentials rather than a limited user account.

    [edit] ..just an afterthought; are you experimenting with WordPress in the network configuration or just single user?

  5. SRD75
    Member
    Posted 1 year ago #

    Performing 1) does not change the symptoms, unfortunately.

    2) My user account is an administrator.

    3) The symptoms occur for 2 local WordPress installations. One has just had Network enabling added to wp-config.php, but the Network has not yet been setup as my user account does not have sufficient privileges. The other is a standard single user installation.

  6. ClaytonJames
    Member
    Posted 1 year ago #

    I just did a quick install on a fresh image of XP SP3, single user account with admin rights:

    - strawberry-perl-5.16.1.1-32bit
    - wampserver2.2e-php5.3.13-httpd2.2.22-mysql5.5.24-32b
    - wordpress-3.4.2

    I could not duplicate the issue. All things being equal, I can't really think of anything that would cause permissions issues with the XP user account. The only obvious difference in my installation is that by default, wp_usermeta > wp_capabilities for the admin account is

    a:1:{s:13:"administrator";s:1:"1";}

    You might try that and see if it makes any difference.

  7. SRD75
    Member
    Posted 1 year ago #

    Thanks for your help Clayton.

    I updated wp_capabilities to the same value and nothing changed.

  8. ClaytonJames
    Member
    Posted 1 year ago #

    I'm stumped. I think I might do a clean WordPress install from a fresh download at this point and see what happens.

  9. SRD75
    Member
    Posted 1 year ago #

    I've just done a new install of a newly download zip file, and the installation process stops at:
    http://localhost/site/wp-admin/install.php?step=2

    This page is blank, and nothing progresses.

    I now recall this happened on my previous installation also.

    If I refresh this page, I receive a message:
    "Already Installed
    You appear to have already installed WordPress. To reinstall please clear your old database tables first."

    I can elect to log in from here, and doing so presents me with the ability to install Plugins, which I can't do on my other installation.

  10. Njurus
    Member
    Posted 1 year ago #

    I have the same problem and after the step 2 in the installation problem does not create the Admin user i went ahead and created the user manually in the DB as per this instruction

    I was able to login but now it tells me that "You do not have sufficient permissions to access this page." after logging in and the url is at localhost/test/wp-admin

    Someone help me. I have been looking for a solution for the past close to 5 hours to no avail.

  11. Njurus
    Member
    Posted 1 year ago #

    I was able to go around it you need to go to the DB and open the wp_options from there go to the "wp_user_roles" columns open it and paste this a:5:{s:13:"administrator";a:2:{s:4:"name";s:13:"Administrator";s:12:"capabilities";a:62:{s:13:"switch_themes";b:1;s:11:"edit_themes";b:1;s:16:"activate_plugins";b:1;s:12:"edit_plugins";b:1;s:10:"edit_users";b:1;s:10:"edit_files";b:1;s:14:"manage_options";b:1;s:17:"moderate_comments";b:1;s:17:"manage_categories";b:1;s:12:"manage_links";b:1;s:12:"upload_files";b:1;s:6:"import";b:1;s:15:"unfiltered_html";b:1;s:10:"edit_posts";b:1;s:17:"edit_others_posts";b:1;s:20:"edit_published_posts";b:1;s:13:"publish_posts";b:1;s:10:"edit_pages";b:1;s:4:"read";b:1;s:8:"level_10";b:1;s:7:"level_9";b:1;s:7:"level_8";b:1;s:7:"level_7";b:1;s:7:"level_6";b:1;s:7:"level_5";b:1;s:7:"level_4";b:1;s:7:"level_3";b:1;s:7:"level_2";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:17:"edit_others_pages";b:1;s:20:"edit_published_pages";b:1;s:13:"publish_pages";b:1;s:12:"delete_pages";b:1;s:19:"delete_others_pages";b:1;s:22:"delete_published_pages";b:1;s:12:"delete_posts";b:1;s:19:"delete_others_posts";b:1;s:22:"delete_published_posts";b:1;s:20:"delete_private_posts";b:1;s:18:"edit_private_posts";b:1;s:18:"read_private_posts";b:1;s:20:"delete_private_pages";b:1;s:18:"edit_private_pages";b:1;s:18:"read_private_pages";b:1;s:12:"delete_users";b:1;s:12:"create_users";b:1;s:17:"unfiltered_upload";b:1;s:14:"edit_dashboard";b:1;s:14:"update_plugins";b:1;s:14:"delete_plugins";b:1;s:15:"install_plugins";b:1;s:13:"update_themes";b:1;s:14:"install_themes";b:1;s:11:"update_core";b:1;s:10:"list_users";b:1;s:12:"remove_users";b:1;s:9:"add_users";b:1;s:13:"promote_users";b:1;s:18:"edit_theme_options";b:1;s:13:"delete_themes";b:1;s:6:"export";b:1;}}s:6:"editor";a:2:{s:4:"name";s:6:"Editor";s:12:"capabilities";a:34:{s:17:"moderate_comments";b:1;s:17:"manage_categories";b:1;s:12:"manage_links";b:1;s:12:"upload_files";b:1;s:15:"unfiltered_html";b:1;s:10:"edit_posts";b:1;s:17:"edit_others_posts";b:1;s:20:"edit_published_posts";b:1;s:13:"publish_posts";b:1;s:10:"edit_pages";b:1;s:4:"read";b:1;s:7:"level_7";b:1;s:7:"level_6";b:1;s:7:"level_5";b:1;s:7:"level_4";b:1;s:7:"level_3";b:1;s:7:"level_2";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:17:"edit_others_pages";b:1;s:20:"edit_published_pages";b:1;s:13:"publish_pages";b:1;s:12:"delete_pages";b:1;s:19:"delete_others_pages";b:1;s:22:"delete_published_pages";b:1;s:12:"delete_posts";b:1;s:19:"delete_others_posts";b:1;s:22:"delete_published_posts";b:1;s:20:"delete_private_posts";b:1;s:18:"edit_private_posts";b:1;s:18:"read_private_posts";b:1;s:20:"delete_private_pages";b:1;s:18:"edit_private_pages";b:1;s:18:"read_private_pages";b:1;}}s:6:"author";a:2:{s:4:"name";s:6:"Author";s:12:"capabilities";a:10:{s:12:"upload_files";b:1;s:10:"edit_posts";b:1;s:20:"edit_published_posts";b:1;s:13:"publish_posts";b:1;s:4:"read";b:1;s:7:"level_2";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:12:"delete_posts";b:1;s:22:"delete_published_posts";b:1;}}s:11:"contributor";a:2:{s:4:"name";s:11:"Contributor";s:12:"capabilities";a:5:{s:10:"edit_posts";b:1;s:4:"read";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:12:"delete_posts";b:1;}}s:10:"subscriber";a:2:{s:4:"name";s:10:"Subscriber";s:12:"capabilities";a:2:{s:4:"read";b:1;s:7:"level_0";b:1;}}}

    Go back to where you were setting the admin role in the DB for the user you had created and in the meta key enter "wp_capabilities
    " While in the meta value enter "a:1:{s:13:"administrator";s:1:"1";}"

    I hope that helps you it did work for me though i am trying to figure out the real problem in this as I should not be having this problem whenever i am installing a new WP on my WAMPSERVER and i tried to joomla wouldn't install so there is something not right somewhere!

Topic Closed

This topic has been closed to new replies.

About this Topic