WordPress.org

Ready to get started?Download WordPress

Forums

WordPress not writing to .htaccess for Permalinks? (7 posts)

  1. lethalreality9
    Member
    Posted 6 years ago #

    I just recently installed WordPress and I'm trying to change my permalinks, but it's not working. I have a blank .htaccess file in my main WP directory and it's set to permissions 644. I read up on permalinks and it said that WP will edit the .htaccess file and if it couldn't, it'd give me the codes to put in it. Both failed. When I changed my permalink to Date and name based it says that the permalink structure is updated, and well it is, but I don't like the index.php at the beginning. How do I get rid of index.php? I only want it to be /%year%/%monthnum%/%day%/%postname%/ and not /index.php/%year%/%monthnum%/%day%/%postname%/

  2. Vocino
    Member
    Posted 6 years ago #

    Do you have "index.php" in your "WordPress Address" or "Blog Address" fields in the Options > General admin?

    If so, take it out and make it just the directory/

  3. lethalreality9
    Member
    Posted 6 years ago #

    No I don't have "index.php" in my "WordPrss Address" or "Blog Address" fields in the Options > General admin.

  4. Chris_K
    Member
    Posted 6 years ago #

    A) Are you positive your host has mod_rewrite on and properly enabled?

    B) You might consider, just for grins, making your .htaccess read-only. Then visit Options -> Permalinks and copy the changes you need to manually add to .htaccess. Change file permissions back to 644 and paste 'em in. See what happens then?

    Out of curiosity, who's your host? Some are rather notorious for their [lack of] support with mod_rewrite.

  5. lethalreality9
    Member
    Posted 6 years ago #

    Yes I am positive that my host has mod_rewrite on and properly enabled.. atleast, I think so! I host on a friend's site which is hosted on a host and I don't know of. I'm pretty sure my .htaccess file works though, since I do have something written in it.

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

  6. lethalreality9
    Member
    Posted 6 years ago #

    I think the host is: http://www.dimenoc.com/

  7. Chris_K
    Member
    Posted 6 years ago #

    Well, the thing is... what you have in .htaccess right now isn't using mod_rewrite, so that doesn't really tell us if it's enabled.

    Did you try my option B from the earlier response?

Topic Closed

This topic has been closed to new replies.

About this Topic