WordPress.org

Ready to get started?Download WordPress

Forums

WordPress not working with mysql 5.0-alpha1 ? (7 posts)

  1. Cena
    Member
    Posted 10 years ago #

    Which version of WP?

  2. Jean-Pierre Michaud
    Member
    Posted 10 years ago #

    ya, but is your blog working after all these bugs ?!".. if yes, it's ok.. the installer is having weird behaviors in many installations... if no, you're not the only one to have problem in a non-standard installation... ;)

  3. Anonymous
    Unregistered
    Posted 10 years ago #

    This is called the Shushbh effect. Heck knows why. It does not seem to effect the install. If you can continue then just keep going. We do not mind a bit of bleeding edge here anyway! You may find the WP docs very informative ;)

  4. dmalloc
    Member
    Posted 10 years ago #

    Hello :) Thank you for you answers but the blog does not work correctly. All drop down fileds which should have some preset values in the Options area are empty. Sometimes errors pop open when I try to set an option, possibly indicating that the table is missing while trying to read the value.

  5. dmalloc
    Member
    Posted 10 years ago #

    Ok. Using this statement works:
    CREATE TABLE wp_optionvalues ( option_id int(11) NOT NULL, optionvalue tinytext, optionvalue_desc varchar(255), optionvalue_max int(11), optionvalue_min int(11), optionvalue_seq int(11), UNIQUE (option_id, optionvalue(85)), INDEX (option_id, optionvalue_seq) );
    Apparenlty the optionvalue(85) vs optionvalue(255) triggers the error.

  6. dmalloc
    Member
    Posted 10 years ago #

    and on we go with the odd effects.
    The original error code:
    SQL/DB Error:
    [Specified key was too long. Max key length is 500]
    ALTER TABLE wp_posts ADD INDEX ( post_name )
    SQL/DB Error:
    [Specified key was too long. Max key length is 500]
    ALTER TABLE wp_categories ADD INDEX ( category_nicename )
    The one I used which works:
    ALTER TABLE wp_posts ADD INDEX (post_name(166));
    ALTER TABLE wp_categories ADD INDEX (category_nicename(166));
    I just double checked. With the steps I mentioned here, the WP install now works without any flaws. The options show in the drop downs now.

  7. dr_njt
    Member
    Posted 8 years ago #

    try this:

    You need to disable Strict Mode in MySQL 5. If you have already installed MySQL 5 goto Start-->MySQL-->Server Config Wizard. Follow through the detailed config steps and deselect 'Enable Strict Mode'.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.