WordPress.org

Ready to get started?Download WordPress

Forums

WordPress not stripping extra spaces like it used to (5 posts)

  1. Delete Me
    Member
    Posted 2 years ago #

    Occasionally (ok more than occasionally) old habits take over and I add an extra space after punctuation. I've been writing in the visual editor lately and I've noticed rather than strip that extra space after a period it adds a    tag, even when I switch to the HTML editor. As a result this causes formatting issues.

    Is this normal behavior for the visual editor, or could a theme/plugin be screwing with things? It used to be that I had to actually add the code   in the HTML editor to force additional spaces, but now that no longer seems to be true.

  2. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    Did you used to have the box checked to correct invalid XHMTL errors checked?

    Admin Dashboard>Setings>Writing...

    Also check the DocType declaration for your site in source code. This may have been modified by a theme or plugin.

  3. Delete Me
    Member
    Posted 2 years ago #

    No, I always keep that disabled.

    Doctype reads as:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" style="background-color: #000000;" dir="ltr" lang="en">
  4. Delete Me
    Member
    Posted 2 years ago #

    It appears the visual editor is now preserving all whitespace instead of stripping them, even when you switch over to the HTML editor. When did it start doing this, or is it a bug?

  5. jjsararas
    Member
    Posted 2 years ago #

    I'm experiencing this too. I use an old version of Microsoft OneNote (03) and I used to be able to paste in and it would strip the spaces. Now, even if I use the paste as plain text feature, it adds an annoying &nbsp.

    Anyone?

Topic Closed

This topic has been closed to new replies.

About this Topic