WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress not showing up (13 posts)

  1. Avexvision
    Member
    Posted 2 years ago #

    After an automatic upgrade to 3.4.1, my site is not showing up anymore.

    http://avexmarketing.com

    As you can see, the WP files are still there, but the page is not loading correctly. I checked the htaccess file and everything seems to be ok. Please let me know if there is a solution to this problem. Thanks in advance.

  2. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    I am afraid you erased all your posts/ contents. I find only your WordPress installation. Do you have a lot of content/ posts? How old is your site? Do you have back ups of database, etc.?

  3. Avexvision
    Member
    Posted 2 years ago #

    I barely have any post/contents so I am not worried about that. My site is about 1 year old, I've had it running for a while but I rarely make changes to it.

    You think I should do a restore from a backup in my cPanel?

  4. racer x
    Member
    Posted 2 years ago #

    No, the database was not erased. You can still access pages like http://www.avexmarketing.com/category/services/, etc.

    Avexvision, I would try switching your theme to twentytwelve and see what happens. This looks like a problem with the exquisite-child theme maybe. You can still log in at http://avexmarketing.com/wp-login.php.

  5. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Yes, making a backup will help you retain any contents. Now tell me if you can login to your dashboard?

  6. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    I would try switching your theme to twentytwelve and see what happens

    A new theme? I too will like to get it. Where can I look for it?

  7. Avexvision
    Member
    Posted 2 years ago #

    I've managed to log in and changed the theme, but still no dice...the homepage is still not showing up.

    But if you go to a page like
    http://www.avexmarketing.com/about-us/
    You can see that I've changed the theme already

  8. racer x
    Member
    Posted 2 years ago #

    Hmmm, very strange. Have you tried visiting the permalinks page? You don't need to make any changes to the settings.

  9. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Yes. Can you make a back up of your site and reinstall WordPress (excepting wp-content)

  10. Avexvision
    Member
    Posted 2 years ago #

    I went inside Cpanel and reverted my WP back to 3.2.1 but the same problem still occurs.

    I guess when I get home I'll first try to reinstall WordPress and then restore my entire cpanel from backup if that doesn't work.

  11. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    I think that should solve the problem.

  12. Avexvision
    Member
    Posted 2 years ago #

    Ok so I talked to hostgator live chat and they told me that they had to add a directory index into the .htaccess file. Now my sites are working again! Here is the .htaccess if anyone is curious. Thanks a lot for the help guys!

    DirectoryIndex index.php index.html
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
  13. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Glad to note that you could solve the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.