WordPress.org

Ready to get started?Download WordPress

Forums

WordPress not showing new posts from ecto (10 posts)

  1. aresnickety
    Member
    Posted 7 years ago #

    I'm using ecto 2.4.2, and for some reason, when I publish a new post, it doesn't show up on my blog front page. But I can go to the permalink or the URL for the post, and it's there. Weirder, when I got to the WordPress (I'm running 2.2, by the way) interface, it's listed as a published post, but it won't show up, even if I edit it and save it via WordPress. And I don't seem to be getting any error from ecto/xmlrpc. Here's the console transcript from posting from ecto:

    Request with URL:
    http://scripts.mit.edu/~aresnick/home/blog/xmlrpc.php
    and data:
    <?xml version="1.0" encoding="UTF-8"?>
    <methodCall>
    <methodName>metaWeblog.newPost</methodName>
    <params>
    	<param>
    		<value><string>1</string></value>
    	</param>
    	<param>
    		<value><string>admin</string></value>
    	</param>
    	<param>
    		<value><string>******</string></value>
    	</param>
    	<param>
    	<value><struct>
    	<member>
    		<name>title</name>
    		<value><string>testing from ecto</string></value>
    	</member>
    	<member>
    		<name>mt_text_more</name>
    		<value><string></string></value>
    	</member>
    	<member>
    		<name>mt_allow_pings</name>
    		<value><i4>1</i4></value>
    	</member>
    	<member>
    		<name>description</name>
    		<value><string>ecto!</string></value>
    	</member>
    	<member>
    		<name>mt_keywords</name>
    		<value><string></string></value>
    	</member>
    	<member>
    		<name>dateCreated</name>
    		<value><dateTime.iso8601>20070621T14:55:13Z</dateTime.iso8601></value>
    	</member>
    	<member>
    		<name>mt_convert_breaks</name>
    		<value><string></string></value>
    	</member>
    	<member>
    		<name>mt_excerpt</name>
    		<value><string></string></value>
    	</member>
    	<member>
    		<name>mt_allow_comments</name>
    		<value><i4>1</i4></value>
    	</member>
    	</struct></value>
    	</param>
    	<param>
    		<value><boolean>0</boolean></value>
    	</param>
    </params>
    </methodCall>
    
    Response:
    <?xml version="1.0"?>
    <methodResponse>
      <params>
        <param>
          <value>
            <string>18</string>
          </value>
        </param>
      </params>
    </methodResponse>
    
    Request with URL:
    http://scripts.mit.edu/~aresnick/home/blog/xmlrpc.php
    and data:
    <?xml version="1.0" encoding="UTF-8"?>
    <methodCall>
    <methodName>metaWeblog.editPost</methodName>
    <params>
    	<param>
    		<value><string>18</string></value>
    	</param>
    	<param>
    		<value><string>admin</string></value>
    	</param>
    	<param>
    		<value><string>******</string></value>
    	</param>
    	<param>
    	<value><struct>
    	<member>
    		<name>title</name>
    		<value><string>testing from ecto</string></value>
    	</member>
    	<member>
    		<name>mt_text_more</name>
    		<value><string></string></value>
    	</member>
    	<member>
    		<name>mt_allow_pings</name>
    		<value><i4>1</i4></value>
    	</member>
    	<member>
    		<name>description</name>
    		<value><string>ecto!</string></value>
    	</member>
    	<member>
    		<name>mt_keywords</name>
    		<value><string></string></value>
    	</member>
    	<member>
    		<name>dateCreated</name>
    		<value><dateTime.iso8601>20070621T14:55:13Z</dateTime.iso8601></value>
    	</member>
    	<member>
    		<name>mt_convert_breaks</name>
    		<value><string></string></value>
    	</member>
    	<member>
    		<name>mt_excerpt</name>
    		<value><string></string></value>
    	</member>
    	<member>
    		<name>mt_allow_comments</name>
    		<value><i4>1</i4></value>
    	</member>
    	</struct></value>
    	</param>
    	<param>
    		<value><boolean>1</boolean></value>
    	</param>
    </params>
    </methodCall>
    
    Response:
    <?xml version="1.0"?>
    <methodResponse>
      <params>
        <param>
          <value>
            <boolean>1</boolean>
          </value>
        </param>
      </params>
    </methodResponse>
    
    Request with URL:
    http://scripts.mit.edu/~aresnick/home/blog/xmlrpc.php
    and data:
    <?xml version="1.0" encoding="UTF-8"?>
    <methodCall>
    <methodName>metaWeblog.getPost</methodName>
    <params>
    	<param>
    		<value><string>18</string></value>
    	</param>
    	<param>
    		<value><string>admin</string></value>
    	</param>
    	<param>
    		<value><string>******</string></value>
    	</param>
    </params>
    </methodCall>
    
    Response:
    <?xml version="1.0"?>
    <methodResponse>
      <params>
        <param>
          <value>
            <struct>
      <member><name>dateCreated</name><value><dateTime.iso8601>20070621T14:55:13</dateTime.iso8601></value></member>
      <member><name>userid</name><value><string>1</string></value></member>
      <member><name>postid</name><value><string>18</string></value></member>
      <member><name>description</name><value><string>ecto!</string></value></member>
      <member><name>title</name><value><string>testing from ecto</string></value></member>
      <member><name>link</name><value><string>http://scripts.mit.edu/~aresnick/home/blog/2007/06/21/testing-from-ecto/</string></value></member>
      <member><name>permaLink</name><value><string>http://scripts.mit.edu/~aresnick/home/blog/2007/06/21/testing-from-ecto/</string></value></member>
      <member><name>categories</name><value><array><data>
      <value><string>uncategorized</string></value>
    </data></array></value></member>
      <member><name>mt_excerpt</name><value><string></string></value></member>
      <member><name>mt_text_more</name><value><string></string></value></member>
      <member><name>mt_allow_comments</name><value><int>1</int></value></member>
      <member><name>mt_allow_pings</name><value><int>1</int></value></member>
      <member><name>wp_slug</name><value><string>testing-from-ecto</string></value></member>
      <member><name>wp_password</name><value><string></string></value></member>
      <member><name>wp_author_id</name><value><string>1</string></value></member>
      <member><name>wp_author_display_name</name><value><string>Alec Resnick</string></value></member>
    </struct>
          </value>
        </param>
      </params>
    </methodResponse>
    
    Request with URL:
    http://scripts.mit.edu/~aresnick/home/blog/xmlrpc.php
    and data:
    <?xml version="1.0" encoding="UTF-8"?>
    <methodCall>
    <methodName>mt.getPostCategories</methodName>
    <params>
    	<param>
    		<value><string>18</string></value>
    	</param>
    	<param>
    		<value><string>admin</string></value>
    	</param>
    	<param>
    		<value><string>******</string></value>
    	</param>
    </params>
    </methodCall>
    
    Response:
    <?xml version="1.0"?>
    <methodResponse>
      <params>
        <param>
          <value>
            <array><data>
      <value><struct>
      <member><name>categoryName</name><value><string>uncategorized</string></value></member>
      <member><name>categoryId</name><value><string>1</string></value></member>
      <member><name>isPrimary</name><value><boolean>1</boolean></value></member>
    </struct></value>
    </data></array>
          </value>
        </param>
      </params>
    </methodResponse>

    Any ideas? Thanks!

  2. Chris_K
    Member
    Posted 7 years ago #

    Are you running wp-cache plugin?

  3. aresnickety
    Member
    Posted 7 years ago #

    Yep--are they incompatible? Or is there a workaround?

  4. Chris_K
    Member
    Posted 7 years ago #

    I'm just kinda spit-balling here, but a theory might be that whatever event that causes wp-cache to realize a new post was made (and to update the cache) doesn't happen when the post comes via an external blog client.

    Try this:
    After you make your next post, visit your Options -> Wp-cache page, scroll down a bit and click "Delete Cache". That'd force a refresh.

    Again, just guessing, but worth experimenting with?

  5. aresnickety
    Member
    Posted 7 years ago #

    Thanks for the tip--I tried deleting the cache, no joy. I also tried reposting after deleting the cache. Still no luck. I then tried deactivating all my plugins, and posting once more. _Still_ no luck.

    I assume people have gotten ecto to work with WordPress 2.2? I'm mostly confused about why the post gets made (so I can link directly to the post) but it doesn't show up on my blog's frontpage.

  6. Chris_K
    Member
    Posted 7 years ago #

    Since not many have been here mentioning Ecto doesn't work, I think we can assume there must be something else going on.

    For instance, if you change to the default theme does the post show up on the front page?

    What category are the posts from ecto in -- and does your theme do any category filtering?

  7. aresnickety
    Member
    Posted 7 years ago #

    I tried deactivating all the plugins, reverting to the default theme, and reposting from ecto, to no avail. Also, in the default theme, when I browse individual posts, I can't get to posts from ecto. So I can type in the url for the specific post from ecto and get to it, but the links to the previous/next post stop short of the ecto posts.

    I've tried posting in various categories, as well; though, my theme does not do any category filtering.

    Thanks for your efforts! I'lll keep trying and looking; let me know if you've any other ideas!

  8. jscottjfs
    Member
    Posted 6 years ago #

    I'm seeing a similar problem; the post appears to be accessible using the post id, but it is not displayed on WordPress as a new post. If you select the category containing the post, it does not show up either.

    This behavior is expected if the post_status is set to "draft".

    I'm not using ecto, but rather another client based on apache xmlrpc (java). I looked directly at the database to determine the state, but you could also use "manage posts" and filter on "Status ...".

    For our software, the boolean for "publish" is always explicitly set to "true" and has always worked, except since we upgraded to WordPress 2.3. I expect the xmlrpc.php code has changed in a subtle way, such that java is no longer passing the correct boolean value and the default is taken instead.

    You might check to make certain you have explicitly set publish to "true", but in my case, it doesn't matter.

  9. jscottjfs
    Member
    Posted 6 years ago #

    Actually, it appears that the blog in question was corrupted in a strange way during the upgrade to 2.3. Exporting to a WXR and re-importing to a fresh blog allowed us to add a new post via xmlrpc with the publish flag set to true.

  10. holmes221
    Member
    Posted 6 years ago #

    I faced the same problem earlier. I send post using windows client to XML-RPC and was wondering why it doesn't show up.

    Solution:
    Check on the posting time. It seems that XML-RPC will only use UTC time. If your time location is GMT+ (in my case GMT+8), it will create a future dated post... hence the post is not showing in HomePage.

Topic Closed

This topic has been closed to new replies.

About this Topic