WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress not sending any emails (4 posts)

  1. stemlund
    Member
    Posted 10 months ago #

    I've discovered an issue on my wordpress site - no emails are being sent - for new user creation, when comments are written, or when a contact form (contact form 7 or jetpack) are filled out. The emails are not sent to spam or regular inbox.

    I even installed WP fresh and was able to get emails to send, but when I set the WP URL and Site URL to make the website live, emails stop working.

    So my WordPress site is installed at http://www.stephenemlund.com/icphotobooth2 - but the live domain name (and what I've changed WP URL and Site URL to is http://www.iowacityphotobooth.com

    I've tried installing and activating WP-Mail SMTP (and just changing the 'from email') and this doesn't work - I haven't tried changing the host/port because I'm not sure what to put there - but changing these on my initial WP install (before reinstalling) didn't help.

    I'm using Godaddy Shared Hosting on Linux, btw.

    What could cause WP emails to stop sending when a the WP URL and/or Site URL is changed?

  2. stemlund
    Member
    Posted 10 months ago #

    the contact form in question is located here - http://www.iowacityphotobooth.com/contact-us - It uses Contact Form 7 - it says the message was sent successfully, but no email is received.

  3. stemlund
    Member
    Posted 10 months ago #

    I've used the following settings with WP-Mail-SMTP:

    From email: wordpress@iowacityphotobooth.com
    From name: Iowa City Photo Booth
    Mailer: Send all WordPress emails via SMTP.
    SMTP Host: relay-hosting.secureserver.net
    SMTP Port: 25
    No Encryption
    Yes: Use SMTP authentication.
    Username: wordpress@iowacityphotobooth.com
    Password: my email password

    When I send a test email I get the following debugging info... which ends with something about thinking the email is spam or a virus content.

    How do I get past this error to successfully using SMTP on my WordPress site?

    Test Message Sent
    
    The result was:
    
    bool(true)
    
    The full debugging output is shown below:
    
    object(PHPMailer)#363 (58) {
      ["Priority"]=>
      int(3)
      ["CharSet"]=>
      string(5) "UTF-8"
      ["ContentType"]=>
      string(10) "text/plain"
      ["Encoding"]=>
      string(4) "8bit"
      ["ErrorInfo"]=>
      string(0) ""
      ["From"]=>
      string(32) "wordpress@iowacityphotobooth.com"
      ["FromName"]=>
      string(21) "Iowa City Photo Booth"
      ["Sender"]=>
      string(0) ""
      ["Subject"]=>
      string(45) "WP Mail SMTP: Test mail to stemlund@gmail.com"
      ["Body"]=>
      string(68) "This is a test email generated by the WP Mail SMTP WordPress plugin."
      ["AltBody"]=>
      string(0) ""
      ["MIMEBody:protected"]=>
      string(69) "This is a test email generated by the WP Mail SMTP WordPress plugin.
    "
      ["MIMEHeader:protected"]=>
      string(491) "Date: Mon, 10 Jun 2013 14:51:51 +0000
    Return-Path: wordpress@iowacityphotobooth.com
    To: stemlund@gmail.com
    From: Iowa City Photo Booth
    Subject: WP Mail SMTP: Test mail to stemlund@gmail.com
    Message-ID: <686695d901c3c613882356e38eeb4f39@www.iowacityphotobooth.com>
    X-Priority: 3
    X-Mailer: PHPMailer 5.2.1 (http://code.google.com/a/apache-extras.org/p/phpmailer/)
    MIME-Version: 1.0
    Content-Transfer-Encoding: 8bit
    Content-Type: text/plain; charset="UTF-8"
    
    "
      ["SentMIMEMessage:protected"]=>
      string(564) "Date: Mon, 10 Jun 2013 14:51:51 +0000
    Return-Path: wordpress@iowacityphotobooth.com
    To: stemlund@gmail.com
    From: Iowa City Photo Booth
    Subject: WP Mail SMTP: Test mail to stemlund@gmail.com
    Message-ID: <686695d901c3c613882356e38eeb4f39@www.iowacityphotobooth.com>
    X-Priority: 3
    X-Mailer: PHPMailer 5.2.1 (http://code.google.com/a/apache-extras.org/p/phpmailer/)
    MIME-Version: 1.0
    Content-Transfer-Encoding: 8bit
    Content-Type: text/plain; charset="UTF-8"
    
    This is a test email generated by the WP Mail SMTP WordPress plugin.
    "
      ["WordWrap"]=>
      int(0)
      ["Mailer"]=>
      string(4) "smtp"
      ["Sendmail"]=>
      string(18) "/usr/sbin/sendmail"
      ["PluginDir"]=>
      string(0) ""
      ["ConfirmReadingTo"]=>
      string(0) ""
      ["Hostname"]=>
      string(0) ""
      ["MessageID"]=>
      string(0) ""
      ["Host"]=>
      string(30) "relay-hosting.secureserver.net"
      ["Port"]=>
      string(2) "25"
      ["Helo"]=>
      string(0) ""
      ["SMTPSecure"]=>
      string(0) ""
      ["SMTPAuth"]=>
      bool(true)
      ["Username"]=>
      string(32) "wordpress@iowacityphotobooth.com"
      ["Password"]=>
      string(12) "password was here"
      ["Timeout"]=>
      int(10)
      ["SMTPDebug"]=>
      int(2)
      ["SMTPKeepAlive"]=>
      bool(false)
      ["SingleTo"]=>
      bool(false)
      ["SingleToArray"]=>
      array(0) {
      }
      ["LE"]=>
      string(1) "
    "
      ["DKIM_selector"]=>
      string(9) "phpmailer"
      ["DKIM_identity"]=>
      string(0) ""
      ["DKIM_passphrase"]=>
      string(0) ""
      ["DKIM_domain"]=>
      string(0) ""
      ["DKIM_private"]=>
      string(0) ""
      ["action_function"]=>
      string(0) ""
      ["Version"]=>
      string(5) "5.2.1"
      ["XMailer"]=>
      string(0) ""
      ["smtp:protected"]=>
      object(SMTP)#362 (8) {
        ["SMTP_PORT"]=>
        int(25)
        ["CRLF"]=>
        string(2) "
    "
        ["do_debug"]=>
        int(2)
        ["do_verp"]=>
        bool(false)
        ["Version"]=>
        string(5) "5.2.1"
        ["smtp_conn:private"]=>
        resource(289) of type (stream)
        ["error:private"]=>
        NULL
        ["helo_rply:private"]=>
        string(139) "250-p3smtphosting01.prod.phx3.secureserver.net hello [68.178.254.18], secureserver.net
    250-HELP
    250-SIZE 30000000
    250-8BITMIME
    250 OK
    "
      }
      ["to:protected"]=>
      array(1) {
        [0]=>
        array(2) {
          [0]=>
          string(18) "stemlund@gmail.com"
          [1]=>
          string(0) ""
        }
      }
      ["cc:protected"]=>
      array(0) {
      }
      ["bcc:protected"]=>
      array(0) {
      }
      ["ReplyTo:protected"]=>
      array(0) {
      }
      ["all_recipients:protected"]=>
      array(1) {
        ["stemlund@gmail.com"]=>
        bool(true)
      }
      ["attachment:protected"]=>
      array(0) {
      }
      ["CustomHeader:protected"]=>
      array(0) {
      }
      ["message_type:protected"]=>
      string(5) "plain"
      ["boundary:protected"]=>
      array(3) {
        [1]=>
        string(35) "b1_686695d901c3c613882356e38eeb4f39"
        [2]=>
        string(35) "b2_686695d901c3c613882356e38eeb4f39"
        [3]=>
        string(35) "b3_686695d901c3c613882356e38eeb4f39"
      }
      ["language:protected"]=>
      array(17) {
        ["provide_address"]=>
        string(54) "You must provide at least one recipient email address."
        ["mailer_not_supported"]=>
        string(25) " mailer is not supported."
        ["execute"]=>
        string(19) "Could not execute: "
        ["instantiate"]=>
        string(36) "Could not instantiate mail function."
        ["authenticate"]=>
        string(35) "SMTP Error: Could not authenticate."
        ["from_failed"]=>
        string(35) "The following From address failed: "
        ["recipients_failed"]=>
        string(45) "SMTP Error: The following recipients failed: "
        ["data_not_accepted"]=>
        string(30) "SMTP Error: Data not accepted."
        ["connect_host"]=>
        string(43) "SMTP Error: Could not connect to SMTP host."
        ["file_access"]=>
        string(23) "Could not access file: "
        ["file_open"]=>
        string(33) "File Error: Could not open file: "
        ["encoding"]=>
        string(18) "Unknown encoding: "
        ["signing"]=>
        string(15) "Signing Error: "
        ["smtp_error"]=>
        string(19) "SMTP server error: "
        ["empty_message"]=>
        string(18) "Message body empty"
        ["invalid_address"]=>
        string(15) "Invalid address"
        ["variable_set"]=>
        string(30) "Cannot set or reset variable: "
      }
      ["error_count:protected"]=>
      int(0)
      ["sign_cert_file:protected"]=>
      string(0) ""
      ["sign_key_file:protected"]=>
      string(0) ""
      ["sign_key_pass:protected"]=>
      string(0) ""
      ["exceptions:protected"]=>
      bool(false)
    }
    
    The SMTP debugging output is shown below:
    
    SMTP -> FROM SERVER:220 p3smtphosting01.prod.phx3.secureserver.net  ESMTP server ready
    
    SMTP -> FROM SERVER: 250-p3smtphosting01.prod.phx3.secureserver.net hello [68.178.254.18], secureserver.net
    250-HELP
    250-SIZE 30000000
    250-8BITMIME
    250 OK
    
    SMTP -> ERROR: AUTH not accepted from server: 500 command unrecognized
    
    SMTP -> FROM SERVER:250 OK
    
    SMTP -> FROM SERVER:250 ok
    
    SMTP -> FROM SERVER:250 ok
    
    SMTP -> FROM SERVER:354 enter mail, end with "." on a line by itself
    
    SMTP -> FROM SERVER:250 merr1l0070QbNh801:LEG:Message dropped for spam or virus content
  4. seowizardaltaf
    Member
    Posted 10 months ago #

    i have the same issue cant admin or the client doesnt get any emails.

Reply

You must log in to post.

About this Topic