WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress Not Recognizsing Page Slug (2 posts)

  1. therealhopeful
    Member
    Posted 6 years ago #

    Hello folks. I've run into a really weird problem with WordPress. It seems that it cannot recognise a page slug, if there are more than 61 characters after the '?' in in the URL.

    For example, I have a page at this location:

    http://www.correctnesscommentary.com/contact/

    This page deterministically displays content depending on what information is fed to it via the URL (GET). I get a 404 error when attempting to go to this address:

    http://www.correctnesscommentary.com/contact/?type=list&action=confirm&address=jfell3%40wi%2Err%2Ecom&name=Jim&code=3

    However, if I trim the URL back by one character at a time and refresh the browser, this URL will work (with reduced page funcionality because of fewer variables):

    http://www.correctnesscommentary.com/contact/?type=list&action=confirm&address=jfell3%40wi%2Err%2Ecom&name=

    As you can see in this example, WordPress seems to only be able to buffer/ignore the first 61 characters after the question mark ('?').

    So, this leads to several questions. Does anyone know if this is a reported bug? I tried to report it, but for some reason I couldn't get into the bug-reporting system. :( Also, where in the wordpress files is this situation handled (variables passed via GET to slugged pages)? I'm pretty good with code, so I could probably fix it myself, if I knew where the fix'n needs to be done. :)

    Thanks!

  2. therealhopeful
    Member
    Posted 6 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic