WordPress.org

Ready to get started?Download WordPress

Forums

WordPress no appearing as homepage (5 posts)

  1. Anonymous
    Unregistered
    Posted 5 years ago #

    Hi

    I'm sure this must have been covered, but I can't find an exact explanation of what I need to do.

    I have installed wordpress, and want it as my homepage. You can see what has happened at:

    http://www.sentientpuddle.co.uk/ - it appears as "Index of" and you have to click on the link.

    I ftp'd it into my public_html folder, as I have done with the installation of every other system I have installed on other sites.

    When you do click on the link, it appears in a very strange format - again you'll need to visit: http://www.sentientpuddle.co.uk/wordpress/

    to see what I mean.

    So I've got two problems:

    How do I get it to display as my homepage, and how do I get it to display properly?!

    Any help gratefully received.

  2. macsoft3
    Member
    Posted 5 years ago #

    >I ftp'd it into my public_html folder

    What exactly is 'it'? A folder titled wordpress that contains WP files or actually various WP files including wp-config.php, wp-login.php, wp-content, wp-admin and others? All you have to do is upload all those WP files into the public_html folder if you want WP to be your website at the root directory.

  3. Anonymous
    Unregistered
    Posted 5 years ago #

    Something similar happened to me just this week as I installed a fresh copy of WP on to the public_html folder. Typing in the domain (ie xxx.com) showed me into a placeholder html file.

    Perhaps you could remove the index.html (or similar) file within the public_html directory and retain the index.php file. That's what I did and my blog showed up automatically when surfed to my site. :)

  4. Sherry Dedman
    Member
    Posted 5 years ago #

    You have wordpress installed in a subdirectory, but you have the wrong information on your options.php file - you have it pointing to your root.

    So your /wp-admin/options-general.php needs to point to http://www.sentientpuddle.co.uk/wordpress/ instead of http://www.sentientpuddle.co.uk/

    or

    you need to delete the whole thing and re-install wordpress in the root directory, and not the wordpress subdirectory.

    -Sherry

  5. Anonymous
    Unregistered
    Posted 5 years ago #

    "What exactly is 'it'? A folder titled wordpress that contains WP files or actually various WP files including wp-config.php, wp-login.php, wp-content, wp-admin and others?"

    'it' is the various WP files including wp-config.php.......etc.

    "All you have to do is upload all those WP files into the public_html folder if you want WP to be your website at the root directory"

    That's all I did. On my homepage I've got an option of a cgi-bin folder and the wordpress folder.

    Thanks for your suggestion council - I've had a look and can't find an index.html file or something similar in the public_html folder.

    I've tried deleting everything and re-installing it, but it does exactly the same.

    And there's also the issue of it not displaying in xhtml (?) when you do click through to it.

    Thanks in advance for any help.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.