WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Network on Dreamhost? (4 posts)

  1. dottavi
    Member
    Posted 1 year ago #

    Hi all. I'm trying the Network Configuration of WordPress on Dreamhost for the nth time. I'm sure I followed all the steps and with version 3.4.2 I did a fresh WP install in a new db/dbhost etc. Changed the config as explained, activated the Network from the Tools menu, than updated the config again, than .htaccess... and then WP is responding (http://dottavi.net) but there's no way to login again.

    http://dottavi.net/wp-admin redirects to
    http://dottavi.net/wp-login.php?redirect_to=http%3A%2F%2Fdottavi.net%2Fwp-admin%2F&reauth=1

    and then it does not move anymore. I insert user and psw but the page remains stuck (ofc I also tried to change psw, but no result)

    Anybody with an experience on this? Thanks a lot
    Alberto

  2. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    Hi, dottavi, I'm both DreamHost's resident WP guru, and a savvy Multisite master :) So hopefully I can help you out!

    One of the more annoying problems that pops up with Multisite is that redirect loop. Normally this is actually a cookie problem.

    The fix is actually pretty easy, and there are three things to do.

    1) Edit your wp-config.php.

    Visit https://api.wordpress.org/secret-key/1.1/salt/ and get new salts/hashes. This should prompt your users to re-login and hopefully generate new cookies.

    2) Dump your cache.

    Sometimes, however, browsers are idiots and you have to flush the local cache. You shouldn't need to dump caching plugins, since that doesn't impact logins.

    3) Delete your cookies.

    I hate this one. Delete the cookies only for your domain if possible. Chrome hides this, but it's doable for all sites.

    I don't see an install on your server right now (I see three folders, but they seem not to be full installs), so I can't look any further.

  3. dottavi
    Member
    Posted 1 year ago #

    Hi Ipstenu, really thanks a lot. Stupid me, I didn't think of it. Yes I deleted everything, purged all the tables from the db, started from scratch again and now I'm up and running

    Really thanks a lot. Best,
    Alberto

  4. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    Not stupid at all :) It really is a weird error.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags