WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Network image upload problem (40 posts)

  1. meglundy
    Member
    Posted 3 years ago #

    I have installed the multi site network on my clients site, so that I may have a regular site and a mobile site:

    http://www.kidzct.com
    http://m.kidzct.com

    The main site is fine, images and media are uploading and appearing fine.

    However when I try to upload images for the mobile site nothing happens, it says they upload but when you go to the media library nothing appears. No thumbnails at all, just the alt text where the thumbnails should be.

    Does anyone have any idea how I can correct this so I can images to upload to the sub site?

  2. What URL is it giving for the image?

  3. meglundy
    Member
    Posted 3 years ago #

  4. meglundy
    Member
    Posted 3 years ago #

    Here is a screen shot of the media library:

    http://kidzct.com/sandbox/error.jpg

  5. Okay, the file IS here: http://kidzct.com/wp-content/blogs.dir/2/files/2011/07/IMAG0371.jpg

    But I noted that NO images are showing up correctly:
    http://m.kidzct.com/wp-content/themes/kidzct_mobile/images/custom_login_logo.gif

    1) What's in your .htaccess
    2) Do you have any hotlink protection turned on?

  6. meglundy
    Member
    Posted 3 years ago #

    Here is the .htaccess file:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    </IfModule>

    How do I check to see if hotlink protection is on?

  7. If you don't know, ask your website. Some hosts have a setting in control panel or plesk that turns it on.

    Now, given than http://m.kidzct.com/wp-content/themes/kidzct_mobile/images/header.png works (and so does http://m.kidzct.com/wp-content/blogs.dir/2/files/2011/07/IMAG0371.jpg )

    I would speculate that your httpd.conf isn't reading that .htaccess. Check with your host that AllowOverride is set to 'All'

    By the way... Are you aware that this is NOT a valid style.css for a theme? Not even a child theme:
    http://m.kidzct.com/wp-content/themes/kidzct_mobile/style.css

    Also this file is just plain MISSING: http://kidzct.com/wp-content/themes/kidzct_mobile/images/custom_login_logo.gif

  8. meglundy
    Member
    Posted 3 years ago #

    Why isn't this a valid style sheet? I'm not makeing a site for someone who is going to be changing their "theme". I'm using the site as a CMS system and the style sheet tests fine in all browsers?

    That image shouldn't even be in the folder sorry.

  9. meglundy
    Member
    Posted 3 years ago #

    Hotlink protection is disabled.

    Any other ideas?

  10. esmi
    Forum Moderator
    Posted 3 years ago #

    Why isn't this a valid style sheet?

    See Theme_Development. WordPress requires very specific comments at the top of the style.css file - whether you are using the site as a CMS system or otherwise.

  11. I would speculate that your httpd.conf isn't reading that .htaccess. Check with your host that AllowOverride is set to 'All'

    Yeah, that.

    And what Esmi said :)

  12. meglundy
    Member
    Posted 3 years ago #

    ok so I ran a test on the server

    http://www.kidzct.com/test.php

    Not sure what your referring too or looking for, can you tell me from this list if I need to change something on the server?

  13. meglundy
    Member
    Posted 3 years ago #

    Ok so we just check the file on the server and according to the httpd.conf file it is set to all.

    Also if your referring to the comments at the top of the css file, I haven't added those yet. This is in the very early stages of production. I understand about all the formalities I just like to make stuff work before I make anything "official"

  14. It's NOT a php setting.

    There is a file on your server called httpd.conf and it's used to, among other things, tell your server account what kind of htaccess calls are permitted. Yours isn't working correctly.

    In MOST cases, this problem is caused by your httpd.conf not having AllowOverride include 'All' for your account. So check for that.

    If you don't know how to edit it safely, call your webhost and have them do it or hire a sysadmin to do it for you.

  15. meglundy
    Member
    Posted 3 years ago #

    That link actually came from my system admin because he wasn't sure what you were talking about.

    Once he figured out it was a file on the server he checked it and it is set to allow all.

    (and yes my host is a friend, who is not a server guy either. So we are learning about this situation from you, sorry if we are frustrating)

  16. Nah, not frustrating :) And good to know where we're starting from.

    What is the whole allowoverride section set to?

    Sadly, the problem is that it's NOT set to let .htaccess pass through some of the complex variations needed for MultiSite, and since every server is different, it's really hard to know exactly what's wrong form our end :/

  17. It's still the same line, he just needs to tinker with it.

  18. meglundy
    Member
    Posted 3 years ago #

    Ok I have the file downloaded and am looking, is this it?

    '
    <Directory "/usr/local/apache/htdocs">
    Options Includes Indexes FollowSymLinks MultiViews
    AllowOverride None
    <IfModule mod_access.c>
    Order allow,deny
    Allow from all
    '

  19. meglundy
    Member
    Posted 3 years ago #

    Better yet just check out the link:

    http://www.kidzct.com/test.txt

  20. meglundy
    Member
    Posted 3 years ago #

    Its not the htaccess file.

    Tell your host the file is part of the server configuration files and it is in there.

    One of the good things about having full access to my server is i can go and find stuff :)

  21. <Directory "/usr/local/apache/htdocs">
    Options Includes Indexes FollowSymLinks MultiViews
    AllowOverride None
    <IfModule mod_access.c>
    Order allow,deny
    Allow from all

    THAT is wrong. Bolded to make sure it stands out.

    Reember I said to set AllowOverride to ALL. Do that :)

  22. meglundy
    Member
    Posted 3 years ago #

    Cool Beans!

    He set the above directory but not this one, I will change it right away and keep my fingers crossed.

    :)

  23. In part it depends on WHERE you installed your files. If they're all in /usr/local/apache/htdocs then you need that to have the allow override set.

    Mine are in /home/ipstenu/public_html/ so I have it set there, for example :)

  24. meglundy
    Member
    Posted 3 years ago #

    Ok so its still not working for me.

    I'm looking again now but I have no clue what to set this file to so it will work.

  25. Yeah, sadly this one is a server config issue, and ... it's just not reading the htaccess correctly.

  26. meglundy
    Member
    Posted 3 years ago #

    So do you have any advice as to what I could do?

  27. <Directory "/usr/local/apache/htdocs">

    Is that actually where your install is located? The vhost for your site will be near the end of the httpd.conf file.

  28. meglundy
    Member
    Posted 3 years ago #

    This is what VH says:

    <VirtualHost *>
    ServerName {my server name}
    DocumentRoot /usr/local/apache/htdocs
    ServerAdmin {my email address}
    </VirtualHost>

  29. DocumentRoot /usr/local/apache/htdocs

    And can you verify that's where your wordpress install lives?

  30. meglundy
    Member
    Posted 3 years ago #

    How do I know where it lives? I know that when I ftp files up i upload them under the public_html folder?

    So am I like Ipstenu and need to change it to that file? Where can I find the path?

Topic Closed

This topic has been closed to new replies.

About this Topic