WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Nav Menu not saving (10 posts)

  1. dankobler
    Member
    Posted 2 years ago #

    I have created an extensive nav menu for my website through the Appearance > Menus tool and for some reason, a few of the pages that I added are no longer showing up and I cannot get them to save when I re-add them. The menu just reverts to it's current state.

    I'm using the Thesis Theme (1.8.4) and just two plugins (Easy rel=author Plugin and Gravity Forms)

    http://www.reviance.com/ (missing Contact Us and Blog from the menu)

    Any help would be greatly appreciated.

  2. racer x
    Member
    Posted 2 years ago #

    The only thing I can think of is that you have a similar menu in the footer and maybe you are editing the wrong one? (the contact and blog are in the footer correctly)

    Trust me, I have gone into the menu editor many times and forgot to make sure I was working on the correct menu!

  3. dankobler
    Member
    Posted 2 years ago #

    I wish it was that easy, but I only have one menu (the footer menu is hard coded)... I've had this happen on another site as well.

  4. racer x
    Member
    Posted 2 years ago #

    To be clear,
    are you saying that when you add the menu items in the menu editor and click "save" the menu items do not save?
    ...or
    Are you saying it looks right in the menu editor after saving but the site is not displaying the items?

  5. dankobler
    Member
    Posted 2 years ago #

    I add the pages to the menu, click save menu and the items I just added are not there (both in the editor and the front end)

  6. dankobler
    Member
    Posted 2 years ago #

    It looks like the WP Menuing system adds some postmeta in the database with the following meta_keys:

    _menu_item_menu_item_parent
    _menu_item_object_id
    _menu_item_object
    _menu_item_target
    _menu_item_classes
    _menu_item_xfn
    _menu_item_url

    For some reason, when I save the menu for my Contact Us and Blog pages, these rows are not added (or saved) for these entries. I'm stuck on this one...

  7. racer x
    Member
    Posted 2 years ago #

    Have you tried switching to the default theme and trying to save the menu items? It sounds like you eliminated a possible plugin issue and if WP is updated and all, we're left with a theme error somewhere? I did see one comment on the theme's page saying they had an issue with pages not saving in the menu ater upgrading.

    Wish I could help more than this.

  8. dankobler
    Member
    Posted 2 years ago #

    I have not tried this. The site is live, so I would rather not be changing the theme. I'm not sure how the WP menu system could be affected by the theme, but then again, I don't know much... :)

    May just have to hard code the menu to fix this. Thanks for your help.

    Anyone else have any ideas?

  9. racer x
    Member
    Posted 2 years ago #

    The site is live, so I would rather not be changing the theme.

    I understand.

    I'm not sure how the WP menu system could be affected by the theme

    Because sometimes, for example, the theme uses what is called a custom Walker class which is a way to tap into the native wordpress nav menu output and alter it.

    I do not know what you have done since posting but I do see the contact item now. The strange thing is that the Blog link is commented out. That is what lead me to think maybe a custom walker class had some effect.

    <!--<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28" id="menu-item-28"><a href="http://www.reviance.com/blog/">Blog</a></li>-->

    The above is your blog link. I really don't know why that would be commented out. The blog page itself is blank so perhaps check your reading settings or some other settings in the theme that indicate which page is to list your blog archives. Maybe there is an error in that setting and the theme is denying the blog link?

    You might try to get support from the theme creators.

  10. dankobler
    Member
    Posted 2 years ago #

    Sorry for the confusion. I did have to go and hard code the menu since I was not able to get the Contact and Blog pages (among others) to save in the WP menu. So, the Blog link you mentioned above is commented out temporarily until we get some content for their blog.

    The curious part is that I'm using the same theme / menu system on dozens of other sites and have never had an issue (same plugins too).

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags