WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] wordpress multisite subdirectories not resolving (2 posts)

  1. greg.smith0
    Member
    Posted 3 months ago #

    Hi Hope someone can help.

    I am trying to set up a multisite on Amazons EC2 platform using Apache PHP.

    I have installed a wordpress and insured pretty HTML is working. I have then gone through Multisite setup. This appeared to go fine but now when I set up a new site the site won’t resolve properly. The mainsite address works fine but the subsite http://54.195.244.100/mytestsite/ resolves eventually but doesn’t load the stylesheet and http://54.195.244.100/mytestsite/wp-admin doesn’t resolve at all. In firefox i get this message
    “The page isn't redirecting properly
    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.”

    I have the .htaccess in the root directory with the following

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    I have access to the virtual host settings and they look like this.

    `DocumentRoot /var/www
    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory>
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    </Directory>`

    I suspect I have missed something simple but my eyes are starting to go square looking for this one so any help greatly appreciated.

  2. greg.smith0
    Member
    Posted 3 months ago #

    Sadly I was right. I was missing the very obvious. I forgot I needed to restart Apache to get the virtual host settings to take.

Reply

You must log in to post.

About this Topic