WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Message Attachment
WordPress Multisite problem (8 posts)

  1. av3c
    Member
    Posted 1 year ago #

    Hi, thanks for this useful plugin, i've a problem with multisite installation of wordpress. In the admin panel when i change the BPMA options and save, appear "You do not have sufficent permission to do that". This plugin is compatible with multisite wordpress installation?
    Thanks again

    http://wordpress.org/extend/plugins/buddypress-message-attachment/

  2. lapincompris
    Member
    Posted 1 year ago #

    Same here.

  3. ckchaudhary
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry guys, I've not tested the plugin with WPMU yet.. Will try and make it compatible with multisite as soon as i get time.. Thnx for the feedbacks

  4. Quint
    Member
    Posted 1 year ago #

    Same here... and thanks for writing it and following through.

  5. Prometheus Fire
    Member
    Posted 1 year ago #

    Looks like its a url redirect issue of some kind. On a multisite setup, the plugin can only be network activated. It really shouldn't, probably best to only allow local activation on the main site. As such, the settings page is on the Network settings, BuddyPress section. A fine place for it, but the URL's get screwy.

    On MU, the url for the settings page is http://domain.com/wp-admin/network/admin.php?page=bp-msgat-settings

    When you attempt to save the settings, it attempts to go to the following URL http://domain.com/wp-admin/admin.php?page=bp-msgat-settings - which, of course, doesn't exist and is the reason for getting the no permissions error.

    There is a quick fix, but it may break single-site installations. Go into /wp-content/plugins/buddypress-message-attachment/includes/admin.php

    Fine line 85 as:
    <form action="<?php echo site_url() . '/wp-admin/admin.php?page=bp-msgat-settings' ?>" name="msgat-settings-form" id="msgat-settings-form" method="post">

    And change it to:
    <form action="<?php echo site_url() . '/wp-admin/network/admin.php?page=bp-msgat-settings' ?>" name="msgat-settings-form" id="msgat-settings-form" method="post">

    All I did was change the output URL to the network admin and it allowed the settings to be saved. No more error. Keep in mind, this fix is MU specific, making the change on a single-site install will break and cause the error message. What really needs to be done is a conditional statement that checks for network activation and then outputs the appropriate URL.

  6. av3c
    Member
    Posted 1 year ago #

    Work for me, Thanks!

  7. nfocom
    Member
    Posted 1 year ago #

    Great plugin.

    It only works for gif format when sending out. I get this error message, "There was an error sending that message: attachement too big or the file type not allowed, please try again" when sending jpg, png and gif when replying to messages.

    Please advise. Thanks.

  8. rain3r.walt3r
    Member
    Posted 1 year ago #

    @Prometheus Fire

    Thanks, works fine now! :)

    @nfocom

    Same here... :(

    Though it works fine with .png files here!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.