WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress MU sub-domain issue (7 posts)

  1. illuminatus7
    Member
    Posted 2 years ago #

    Hi all,

    I have a WordPress MU with sub-domains installed and configured on Nginx. Currently there are 4 sub-domains. I need www before each subdomain. I have mentioned www.subdomain.example.com directly as the sitename, But there is only one that isnt working with www.

    Can anyone tell me what must be causing this problem?

    Thanks in advance :)

  2. Having www before a subdomain isn't normal...

    You'll have to set up aliases on your server for ServerAlias www.subdomain.domain.com and probably check with your host if SUB subdomains are even allowed.

  3. illuminatus7
    Member
    Posted 2 years ago #

    @Ipstenu, yeah I know that sub-domains should not have 'www' but actually this is what a client of mine is demanding :)

    Also, sub-domains are allowed by the host. Will give a try setting up the ServerAlias and check.

    Any other help would really be appreciated though.

  4. Sub-SUB-domains are not the same as subdomains.

    That is, most hosts allow subdomain.domain.com

    Not all allow other.subdomain.domain.com

    And that's really what you're doing.

  5. illuminatus7
    Member
    Posted 2 years ago #

    Oh. Got it. But I have 4 sites and 3 of them are working fine. I have this issue with only one site.

    I have just named the URL with www.. Hence this is not a part of a sub-SUB-domain, but a sub-domain.

    1) Sub-domain: http://www.subdomain
    2) Domain: example
    3) TLD: com

    Hence it becomes http://www.subdomain.example.com

  6. Check with your host.

    I know you're setting the subdomain to www[DOT]sub BUT that only works if your host set up the server to handle that. See it KNOWS that . between www and sub means "Another subdomain!" so you have to be sure.

  7. illuminatus7
    Member
    Posted 2 years ago #

    @Ipstenu Thanks for all your help. The issue is solved. The DNS from the host panel needed to be configured

    Cheers!

Topic Closed

This topic has been closed to new replies.

About this Topic