WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Mainblog should run on www (5 posts)

  1. Rezzanjin
    Member
    Posted 2 years ago #

    Hello, i have my blog sehenswuerdigkeiten.co i just liked to start there something but i got stuck again in the dilemma that the WP Blog is running, but i can get the Main Blog only on http://sehenswuerdigkeiten.co/ and NOT on http://www.sehenswuerdigkeiten.co/ as i would like to have.

    Where can i change that? I tried to install WP by using that path from the beginning, but when it comes to enabling WPMU it tells me that i should install The Blog on http://domain.tld/ where i could run it also with www.
    But where to make the setup for that?

    I tried to make the install by following all instructions of the Codex, but even there i can't find an answer.
    What i didn't tried now was to install it on http://www.domain.tld/ and when it tells me to change it to the http://domain.tld/ that i just make the change in the wp-config, maybe that was what the install means. I will see, but thats already the fifth try out and i don't come any closer to fix it.

    Regards

  2. Rezzanjin
    Member
    Posted 2 years ago #

    As i said i have tried it now again. The Blogs runs fine on www. but now the http://domain.tld/ isn't available anymore, to much redirections. Seems like the MU Blogs tries to create a new user or something like that.

    All the time when in used a NORMAL WP, i could install in on www. or not and depend on what i took, i got a redirtection for the other one. Could i get that with a WP MU blog also?

    Or do i oversee here something?

    Regards and Thanks

  3. What you should do, BEFORE you enable MultiSite, is go to Settings -> General and make your site address and blog address as http://domain.com

    Verify that works for both domain.com and http://www.domain.com

    THEN turn on MultiSite.

  4. Rezzanjin
    Member
    Posted 2 years ago #

    Hello Ipstenu,
    i have done it now the way you have said. But isn't it now the way, that the site is always without www?

    I get always redirected to http://domain.com, even if i type http://www.domain.com.

    That is where i ended up always and i begin to think that my wish isn't possible to solve the way i liked it; the Domain is always WITH www. to open/redirected. Correct?

    The only way now would be creating a www Subdomain in WP, use a special theme and make a static website out of this theme and using it for the http://domain.com site AND http://www.domain.com, so that both sites show up the same content.

    Regards

  5. You can't make a subdomain as www. It's not permitted by the software.

    Go look in your database and see if your main site is saved as domain.com or www,domain,com

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.