WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress MU load index.php page for single post. (15 posts)

  1. Er_Maqui
    Member
    Posted 1 year ago #

    Well,

    I have a wordpress MU installed since 3.4 aprox, and i've detected a failure on a theme, with the excerpt posts option (The problem appears on the first moment, and i have now).

    Initially, i can't think who is a wordpress failure. But, after getting help from the theme creator, i've detected the failure become from wordpress.

    On the network, when i go to read a single post, the system loads the index.php page instead of single.php.

    Anyone can view and review the conversation between me and the support of the theme. On this conversation are the details, because this failure hasn't been detected by me.
    The link to the post on the theme support are here. A link to the blog are here.

    The .htaccess are configured as suggested by wordpress, and revised on 3.5.1 version. It's this:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    If i can review anything, i doesn't have problem. This failure are a problem with my current theme, because them relies on the single.php page for the excerpt configuration.

    Thanks,

  2. Initially, i can't think who is a wordpress failure. But, after getting help from the theme creator, i've detected the failure become from wordpress.

    Easy test. Switch to another theme. Same problem?

  3. Er_Maqui
    Member
    Posted 1 year ago #

    I have this problem on two different themes, and another themes without problems.

    But, my problem aren't feel-like related. There's a technical problem. As the theme developer says:

    For some reason, and this is what I don't know why, when you click on the link to the single page, WordPress is instead using the index.php page to view the post. That is NOT the same at all as the single.php code that should be getting used.

    There's my problem, and the solution aren't on the theme, i think. Also, i can be wrong, but if the .htaccess doesn't redirect nothing to single.php, this file never be loaded.

  4. Yeah, I read what the dev said. Thing is, if it works on, say, Twenty Eleven, but not on their themes, then ... it's probably not WP.

    Did you edit the theme functions.php at all?

  5. Er_Maqui
    Member
    Posted 1 year ago #

    No, i haven't edited the theme. I'm not very skilled on WP themes already.

  6. Did you try your site with the default theme? Twenty Eleven or Twenty Twelve?

  7. Er_Maqui
    Member
    Posted 1 year ago #

    Really no. But, i've say at the first posts, i've tested some themes. Two of them have this failure, another not.

    As i've told on the first post:

    Anyone can view and review the conversation between me and the support of the theme. On this conversation are the details, because this failure hasn't been detected by me.
    The link to the post on the theme support are here.

    You can view on this post detailed information and opinion from more skilled WP Theme developers.

  8. Er_Maqui
    Member
    Posted 1 year ago #

    I can try to use any other theme. But, i can't difference if the page using to build its index.php or single.php.

    This issue have been detected by a theme developer, not by me.

    Now, I'm trying to learn to change themes, but still, one as complex as I have i can't change it, at least for now.

    I do not know how to do the process, how to select the page to load, and other procedures that, in my point of view, does wordpress. But to start, I doesn't know that are delegated by wordpress to themes and what not, so if I come to ask for help (as I asked to the theme developer) is that I require, not because they want to disturb others, or that do my work for me.

  9. Really no. But, i've say at the first posts, i've tested some themes. Two of them have this failure, another not.

    There IS a reason I'm pushing you about the default themes. We know those work with WP out of the box. If THEY have an error, then we know for sure your install is buggered. If they do NOT, then we know it's not core WP. This is a part of the debugging process, and when you get folks telling you to turn off all your plugins and switch back to a default theme, we know what we're talking about :)

    So yes, I know you tested OTHER themes. I really want you to test SPECIFIC themes for a reason. It gives us information we need.

    This issue have been detected by a theme developer, not by me.

    That's nice. I think he's partly wrong. I do not believe this is a Core WP error (no one else has it, a core WP error would be a little easier to reproduce on all themes). I think it's (a) a theme error, (b) a plugin/theme conflict, or (c) a server problem.

    I would like to narrow that down, but you have to give a little and work with us and test like we're asking.

    Make a brand new site on your network and see if you can reproduce it, but at the end of the day, one person out there has the ability to test and debug. And that person is you. We can only offer you advice from years of experience.

  10. Er_Maqui
    Member
    Posted 1 year ago #

    Well, i have enablet Twenty-Twelve theme on one site of the network. How i can detect if the post page are using single.php or index.php (this is the problem detected with another theme)?

  11. Er_Maqui
    Member
    Posted 1 year ago #

    I've edited the theme, and on the file single.php, on the line '<div id="content" role="main">' i've wrote "The Single" text at the end.

    When i load a post, i can't see this text or find it on the source. I think really i'm viewing index.php page.

    The address are http://blogs.enelia.com/.

  12. Try using this single.php

    https://gist.github.com/4675095

    Also - turn off ALL PLUGINS for that site.

  13. Er_Maqui
    Member
    Posted 1 year ago #

    I've modified the single.php with our file but i can't find the comment "This is for testing". I can't find the word "testing" at all.

    I'm configuring a brand-new network for testing, because on the actual network i have some network-wide plugins who i can't deactivate.

  14. Er_Maqui
    Member
    Posted 1 year ago #

    Well, i've find the problem. It's a network-wide plugin, Google authorship for multiple authors. When i activated them, the single.php page debug messages dissapears.

  15. Er_Maqui
    Member
    Posted 1 year ago #

    I think this issue is resolved / closed.

Topic Closed

This topic has been closed to new replies.

About this Topic