WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Domain Mapping
WordPress MU Domain Mapping plugin 0.5.2 - mysteriously still not working (6 posts)

  1. rentageek
    Member
    Posted 3 years ago #

    I must be missing something... Although, it feels like I've tried everything.

    I've tried sub-domains and sub-directories (used host files and/or DNS to test redirects)... I've read several tutorials and followed them very closely...

    No matter what I do, none of the internal links are working on the sites. Files upload to the correct directories, wp-login pages come up for each mapped domain accurately.

    However, if I try to go to mappeddomain.com/about/ (the default wp about page) - I get a 404 error because my web server is looking for a file at /var/www/about

    Here is an excerpt from my apache2 error.log:

    [Tue Oct 19 08:40:56 2010] [error] [client 11.11.51.66] File does not exist: /var/www/feed
    [Tue Oct 19 08:40:56 2010] [error] [client 11.11.51.66] File does not exist: /var/www/comments
    [Tue Oct 19 08:40:57 2010] [error] [client 11.11.51.66] File does not exist: /var/www/about, referer: http://mappeddomain.com/
  2. Look like you forgot the step to show the server where to direct your mapped domain.

    In cpanel, it's parking (if your WP install is irght in public_html), otherwise, make a ServerAlias. that mapped domain has to be directed to the folder where your WP install is.

  3. rentageek
    Member
    Posted 3 years ago #

    Andrea,

    Thanks again for the response.

    I have the ServerAlias configured in my virtual server config in sites-available/ and the site is enabled.

    The main index shows up, with posts and images in posts, but single post and page links are not showing up. Weird.

    Still getting this error in the /var/log/apache2/error.log
    [Tue Nov 23 09:32:12 2010] [error] File does not exist: /var/www/2010, referer: http://mappeddomain.com/

    Here is my virtualhost config for my apache2 root dir /var/www - I'm hosting many sites with no issue in other users directories...

    <VirtualHost *:80>
            ServerAdmin ben@mappeddomain.com
            ServerName www.mappeddomain.com
            ServerAlias *.mappeddomain.com
            ServerAlias mappeddomain.com
            DirectoryIndex index.html index.php index.htm index.shtml index.cgi index.php3
    
            DocumentRoot /var/www
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>
            #Indexes + Doc Root
            DirectoryIndex index.html index.php index.htm index.shtml index.cgi index.php3
            DocumentRoot /var/www
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>
            ScriptAlias /cgi-bin/ /var/www/cgi-bin/
            <Directory "/var/www/">
                    AllowOverride None
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            </Directory>
    
            ErrorLog /var/log/apache2/error.log
  4. rentageek
    Member
    Posted 3 years ago #

    Also, I'm sure that my .htaccess and mod_rewrite is on

    The mod is enabled:

    ./mods-enabled/rewrite.load

    My .htaccess:

    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
  5. and then it's disabled with this line

    <Directory "/var/www/">
    AllowOverride None

    near the bottom.

  6. rentageek
    Member
    Posted 3 years ago #

    That did the trick. I completely forgot that directive applied to .htaccess files. Wow. Great catch!

    I changed it to:

    AllowOverride All

    ...and now, it looks like I might be in business. Thanks again!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic