WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress memory usage - are others hitting the wall at 64mb? (4 posts)

  1. bigpacific
    Member
    Posted 3 years ago #

    Ever since we upgraded to 3.1.3 we are experiencing out of memory error messages when trying to add an image to a post.

    We are on 64mb of memory, shared hosting, one domain and wordpress install, 20 plugins of which most are things like Facebook like button, share this, google analytics, commentluv, rss footer, and si captcha/topsy blocker.

    To go to the next level up for hosting our costs would go from $100/yr to $50/month - considering all we want is the memory upgrade to 128.

    Is this a growing problem as wordpress continues to roll out upgrades? Why are we suddenly running into a wall, our blog is not really that big: http://www.colleenfriesen.com/blog

    So bummed, have done some comparison shopping at hosts with tested & proven support and security/backups, and they're all about the same.

    Anything else we can do to fix things so we can upload images again?

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Try reducing the number of plugins you are using.

  3. bigpacific
    Member
    Posted 3 years ago #

    Hi, disabling all plugins had no result - same error. After some further troubleshooting it turned out the images the client was attempting to upload - she was doing upload-from-camera and a typical image was 4mb, way too big. A resized 72-dpi image solved the problem.

    I would encourage anyone experiencing a memory error when trying to upload an image or images within the wordpress admin interface to ensure their images have been optimized and resaved at 72 dpi, and to use FTP for larger files.

  4. Hugh
    Member
    Posted 2 years ago #

    I have this problem too. I found the same solution, that reducing my dpi setting to 72dpi works. In My case I upgraded my server package to a virtual private server with 2300mb and then later reduced to 900mb of RAM and still had the same issue. But when I resized the image down to 72 DPI then that is when WordPress did not choke up.

Topic Closed

This topic has been closed to new replies.

About this Topic