WordPress.org

Ready to get started?Download WordPress

Forums

WordPress <title> (6 posts)

  1. revlimiter
    Member
    Posted 4 years ago #

    Hey guys,
    Couple of quick questions about WordPress <title> tags:

    http://www.kimstewart.ca/blog/

    Currently, my WordPress blog title reads "KimStewart.ca" on my blog index page.
    This is what I have set as the Blog Title in the WordPress control panel.

    However, I would like for it to read "KimStewart.ca | Blog" on my blog index page. How can I do this?

    As well, for the individual post pages themselves, http://www.kimstewart.ca/blog/donald-trumps-think-like-a-billionaire/
    It currently shows "KimStewart.ca ยป Donald Trump's Think Like A Billionaire" as the title.
    I would like for it to read "Donald Trump's Think Like A Billionaire | KimStewart.ca"
    (I think this will help SEO a bit having the post name first)

    This is the code I am currently running to show titles on my WordPress blog:
    <title><?php bloginfo('name'); ?> <?php if ( is_single() ) { ?> <?php } ?> <?php wp_title(); ?></title>

    Thanks!

  2. chowell18
    Member
    Posted 4 years ago #

    Just download & install the All-In-One-SEO-Pack plugin. Set a few options & you're good to go.

  3. revlimiter
    Member
    Posted 4 years ago #

    Thanks for the info, chowell18
    I have now installed All-In-One-SEO-Pack and it seems to be working for the blog index page now.
    http://www.kimstewart.ca/blog/

    However, the Page titles are not now.
    %page_title%

    Same goes for the 404, Search, Categories, etc.
    http://www.kimstewart.ca/blog/donald-trumps-think-like-a-billionaire/

    Any ideas?
    Thanks!

  4. chowell18
    Member
    Posted 4 years ago #

    Ya, you need to append whichever fields you want displayed for the various types of pages. (in the settings page)

    For a post:
    %post_title% | %blog_title%

    For a page:
    %page_title% | %blog_title%

    There are variables for each type of page, so it's a matter of preference.

  5. revlimiter
    Member
    Posted 4 years ago #

    hmmm, well the weird thing is, none of these seem to work %page_title%, %post_title%

    but when I disable SEO Pack it shows the post in the <title> again

    Maybe I should try <?php wp_title(); ?> in the SEO Pack settings page?

  6. revlimiter
    Member
    Posted 4 years ago #

    bump --- any ideas?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.