WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Loads Slow At High Traffic Times (7 posts)

  1. ian2
    Member
    Posted 8 years ago #

    Hi,

    Whenever my blog is linked by sites with high traffic -- thus giving me high traffic, my server/wordpress slows down and ultimately does not load. I am told that this is due to WordPress being MYSQL dependent and using all my connections up. I am being told that the situation would be better if my MYSQL databases/tables were optimized. I am asking what you would suggest for me to do to fix this so I don't have the slow load problem. If you can fix this please let me know -- I'll pay.

    Thanks,

    Ian

  2. chaaban
    Member
    Posted 8 years ago #

    you can use wp-cache plugin

    http://mnm.uib.es/gallir/posts/2005/02/02/111/

    WP-Cache is extremely efficient WordPress hack –not a simple plugin– for page caching. It allows to serve hundred of times more pages per second, and to reduce the response time from several tenths of seconds to less than a millisecond.

    You can still pay me if u want :p

  3. ian2
    Member
    Posted 8 years ago #

    Okay thanks .. like I said I'm not saavy ... am I correct in doing this:

    (Manually doing it)

    Taking all the files in the zipped file and put them in the /wp-content directory and in the /wp-content/plugins directory .. create a folder named /wp-content/cache .. editing wp-config.php and put that line of code in there and then disabled gzip.

    Will this plugin in work for say .. if I get 20,000 unique hits an hour?

    Thanks a lot.

  4. chaaban
    Member
    Posted 8 years ago #

    Upload to your plugins folder, usually wp-content/plugins/ and unzip the file, it will create a wp-content/plugins/wp-cache/ directory.

    If you have Gzip Compression enabled turn it off (in Options->Reading).

    Create wp-content/cachedirectory and make sure the web server can write in it.

    Make wp-content writeable by the web server.

    Create a symbolic link from wp-content/advanced-cache.php to wp-content/plugins/wp-cache/wp-cache-phase1.php.

    ln -s wp-content/plugins/wp-cache/wp-cache-phase1.php wp-content/advanced-cache.php

    Add the following line to your wp-config.php file:

    define(’WP_CACHE’, true);

    Go to “Options� administration menu, select “WP-Cache� from the submenu and enable cache.

    This plugin should work it will reduce the mysql queries .

    so instead of having 200 requests for a page (mysql queries .... , .... etc) it will request a static page

  5. ian2
    Member
    Posted 8 years ago #

    Thanks, what does "Create a symbolic link" mean?

  6. ian2
    Member
    Posted 8 years ago #

    Here's what I did ... created a directory named wp-cache in /plugins ... uploaded the files in the zip folder ... created a directory named cache in /wp-content ... went into wp-config and added that line ... activated the plugin .. and then enabled .. it created advanced-cache.php and wp-cache in /wp-cotent. Nothing.

    Thanks.

  7. ian2
    Member
    Posted 8 years ago #

    I amable to enable the plugin but I don't see anything on the cache meter going up on the plugin panel.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags