WordPress.org

Ready to get started?Download WordPress

Forums

Link Library
"WordPress Link Manager is inactive" message (9 posts)

  1. cullaloe
    Member
    Posted 1 year ago #

    I just started getting this message after the latest update. The link list works just fine at the moment, and I can't install the plugin demanded because it's not compatible with my current version of WP (3.4.2). I got the message - but now it's distracting me from other messages I do need as I administer my site.

    Can I disable this message anywhere?

    http://wordpress.org/extend/plugins/link-library/

  2. ahcreative
    Member
    Posted 1 year ago #

    Me too after last update:
    "WordPress Link Manager is inactive. To take full advantage of Link Library in WordPress 3.5 or higher, please install and activate the Link Manager Plugin."

  3. advancedstyle
    Member
    Posted 1 year ago #

    Same here, but dumb*** decided to add an admin wide notification message.

  4. alfredo49
    Member
    Posted 1 year ago #

    the same , i hope in the next release this issue be fixed

  5. xad
    Member
    Posted 1 year ago #

    edit this:

    link-library/link-library.php

    find:

    function link_manager_missing_msg() {
    echo "<div id='link-library-warning' class='updated fade'><p>" . __('WordPress Link Manager is inactive. To take full advantage of Link Library in WordPress 3.5 or higher, please install and activate the Link Manager Plugin.', 'link-library') ."</p></div>";
    }

    and replace with:

    function link_manager_missing_msg() {
    }

    message is gone ;-D

  6. mwmconsulting
    Member
    Posted 1 year ago #

    Thanks for the fix, xad, but is this the best way to proceed?

    Perhaps the Link Library devs need to fix something instead.

    BTW, WP 3.5 isn't the latest version. Interesting it should even display that message.

    - MWM

  7. Yannick Lefebvre
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry for the annoying message folks. The latest update removes it if you are running 3.4.x.

    The reason for this message is that the Links section will be disabled on new installations of WordPress starting in version 3.5, which is due to be released soon. To activate it, new users will need to install a plugin called Link Manager. The purpose of this message is to let people know that they installed and activated Link Library without having an active Link Manager.

    For users upgrading, the Links section should remain visible, and that message will not appear.

  8. Yannick Lefebvre
    Member
    Plugin Author

    Posted 1 year ago #

    As for having made the message displayed across the whole admin, I followed queue from the way other plugins display admin wide messages when an important thing is missing (e.g. akismet key).

    dave111223 => When using free open source plugin, calling the author names when he/she spends countless hours developing a plugin is no way to thank someone for the hard work that they put in their work.

  9. advancedstyle
    Member
    Posted 1 year ago #

    Sorry my comment was harsh, I had assumed this added code was in an attempt to coerce users into buying some kind of "Pro" upgrade for the plugin....whereas it appears it was just a genuine coding mistake. My apologizes.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic