WordPress.org

Ready to get started?Download WordPress

Forums

WordPress killed all the subdirectory sites. HELP!! (15 posts)

  1. soam
    Member
    Posted 2 years ago #

    Our main domain was http://www.abc.com and we had active collab PMS setup at http://www.abc.com/project

    Just now, we took down the existing wordpress site and moved our brand new wordpress site to http://www.abc.com folder.

    Since then, http://www.abc.com/project is not accessible.

    When permalinks is OFF, it says INTERNAL SERVER ERROR.

    When permalinks is ON, it says 404 ERROR NOT FOUND.

    Whats the issue ?

  2. Since then, http://www.abc.com/project is not accessible.

    ...

    When permalinks is ON, it says 404 ERROR NOT FOUND.

    Have you tried resetting your permalinks?

    http://www.abc.com/wp-admin/options-permalink.php

    Also, for permalinks to work, you need to have mod_rewrite enabled for your site.

  3. soam
    Member
    Posted 2 years ago #

    I gave the url as an example.

    And wordpress site works fine when permalinks are on.

    Just it has killed the access to project site.

    Got it ?

  4. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    nope, we do not...please follow forum rules and post actual site content

  5. soam
    Member
    Posted 2 years ago #

    We have already restored the site to the old working wordpress site, so its good now.

    But we have to move the new site soon, so I need to get this fixed asap.

  6. The reason Jan suggested resaving the permalinks is that if you DO NOT have a page named /projects/ then the physical folder will always take precedence over a virtual one. Also if you just MOVED a site, you often have to resave things to make 'em work right again :)

    Just now, we took down the existing wordpress site and moved our brand new wordpress site to http://www.abc.com folder.

    Can you possibly install WP in a folder on abc.com? That is have it in abc.com/blog and then use this trick: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory#Using_a_pre-existing_subdirectory_install

  7. soam
    Member
    Posted 2 years ago #

    I did save the permalinks 3-4 times, but every time, it kept on saying 404 not found for /project page .

    And when I switched off permalinks, it said, internal server error.

  8. Right, we got that. Your fancy permalinks aren't working on the new site.

    What steps have you taken to diagnose this on the new site?

    - Have you tried deactivating all of your plugins

    - Switching to the Twenty Eleven theme

    - Confirmed that mod_rewrite is configured and that your directory on your Apache configuration contains something like this

    <Directory /var/www/somewhere>
       Options FollowSymLinks -Indexes
       AllowOverride All
    </Directory>

    - Switched to the non-fancy permalinks ?p=123 just to see that something else is not going on?

    For permalinks to work, you need mod_rewrite enabled and functioning. Can you test that?

    Let us know and provide some information and us volunteers may be able to assist you.

  9. soam
    Member
    Posted 2 years ago #

    We have a wordpress site on the same domain since one year and permalinks work fine , also the project.

    Its just this new site, which is acting weird.

    1. mod_rewrite is on.
    2. I have tried by switching on/off permalinks. WordPress works fine, but project is killed on both the situations.

  10. I have tried by switching on/off permalinks. WordPress works fine, but project is killed on both the situations.

    Woah woah wait WHAT!?

    Projects dies with permalinks OFF?

    What's in your .htaccess? The WHOLE thing in that master abc.com folder. Put it on pastebin if it's way too long.

  11. soam
    Member
    Posted 2 years ago #

    Yes, it dies with permalinks off.

    Here is the htaccess.
    http://pastebin.com/download.php?i=nzdpsVaF

    http://pastebin.com/nzdpsVaF

  12. Simply as a test, try renaming that .htaccess to .htaccess-save and put just the WordPress additions into that file like so.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    See if that makes a difference or not.

  13. soam
    Member
    Posted 2 years ago #

    Yes, that I tried yesterday night and no difference :(

  14. That's totally bizarre...

    Here's the thing: just a plain WordPress install should work right out of the box without any .htaccess file, using the Twenty Eleven theme, and no plugins activated.

    If I'm reading this correctly, when you disable fancy permalinks the project (is that a page or post?) dies. If you enable permalinks, it doesn't die but you get a 404 error.

    When you say it dies, does that mean you get a white blank page or an error message?

    Are you running any plugins? When you switch to the Twenty Eleven theme can you use permalinks on posts with just the .htaccess file that WordPress generates and nothing else?

  15. soam
    Member
    Posted 2 years ago #

    Ok tried removing htaccess and letting WP create it again, but no good.

    Also tried switching off all the plugins, no good.

    Still http://skysoftbackup.com/project is 404 :(

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.