WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress keeps adding a subfolder and breaking (9 posts)

  1. ccsm
    Member
    Posted 5 years ago #

    I have a unique set up for my wordpress. The files are located in the root directory, but I have the front page set in the General settings to display at http://www.mysite.com/blog/.

    Unfortunately, WordPress keeps automatically creating a subfolder named "blog" and when it does this is breaks the site. The subfolder is empty, so when people visit mysite.com/blog they find a "nothing found" error.

    Why is WordPress creating this folder and how can I stop it from doing this?

  2. What plugins do you have?

    You could make a symlink from 'blog' back to root, but it's rather backwards to me. Most people want to go 'My blog is in 'blog', but I want it to act like it's in root.'

  3. ccsm
    Member
    Posted 5 years ago #

    Yeah, it's a weird set-up, I agree. It's an old domain that has gone through several incarnations over the years. A URL with baggage, I guess you could say.

    I made the /blog/ directory, stuffed it with an index.php file that has a PHP redirect script that redirects to the root. That seems to work, but the site no long shows up at http://www.mysite.com/blog/. With this method I might as well just leave that redirect and change the general settings to display the blog at the root. It negates my master plan.

    Do you think that'll matter to google and SEO, etc.? I've heard Google penalizes for redirects, but sometimes it's hard to know what Google advice is good and what's jive.

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    WordPress should not be creating any sort of "blog" folder. How are you making it do that?

  5. ccsm
    Member
    Posted 5 years ago #

    It seems to do it whenever I upload a photo or sometimes even when I don't. It creates a /blog/wp-content/uploads/2009/01/file.jpg subdirectory. Seems really odd to me too.

    My plugins are:
    Akismet
    All in one SEO
    Audio Player
    Custom Query String Reloaded
    Redirection

    Can I change permissions somewhere to fix this?

  6. Ah, on your admin panel, go to Settings and click on Miscellaneous .

    Change 'Store uploads in this folder to /wp-content/uploads/

  7. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Leave off the leading slash. Make it "wp-content/uploads".

  8. ccsm
    Member
    Posted 5 years ago #

    Ah! I think that'll do it. That's much, that's great help.

  9. Whoops, good catch, Otto!

Topic Closed

This topic has been closed to new replies.

About this Topic