WordPress.org

Ready to get started?Download WordPress

Forums

wordpress isn't playing nice with php.ini (4 posts)

  1. nadine00
    Member
    Posted 2 years ago #

    Hi,

    So. Weird thing. I needed to change the max file upload for wordpress, on dreamhost. I went and followed their page (http://wiki.dreamhost.com/PHP.ini) using this script (http://sxi.sabrextreme.com/phpini).

    Funny thing. WordPress doesn't want to listen. It says 20MB. It is not. In fact I can't even upload a PDF.

    This happened to me using bitnami as well (http://answers.bitnami.org/questions/632/bitnami-wordpress-phpini)

    So...I'm wondering if this a wordpress thing? I haven't had an issue before. I don't know why its acting up now.

    Anyone else experience this? Suggestions? Its really frustrating, and I just am so close to finishing something and this is the last thing standing in the way.

    Thanks

  2. Rev. Voodoo
    Volunteer Moderator
    Posted 2 years ago #

    When did you edit php.ini?

    Depending on your server, it can take a day or so for a change like that to be picked up, unless you are able to restart your own server

  3. nadine00
    Member
    Posted 2 years ago #

    Over a day ago.

    The thing tho is if you do it on bitnami, you just restart your own local server. After restarting the local server, it still wasn't picking up the new setting.

    Also: deleting the self-done php.ini from dreamhost causes WP just go back to 7MB right away. No "I can't upload that 600kb pdf" warning.

    Which is why I'm starting to think its a bug of some kind.

  4. Rev. Voodoo
    Volunteer Moderator
    Posted 2 years ago #

    if you do a phpinfo() file, have the settings took?

    My WP allows uploads up to 8gb, with zero modifications to it.... Obviously that (8gb) would never work.... I set it high a while ago when trying to upload music through a different program that kept failing

Topic Closed

This topic has been closed to new replies.

About this Topic