WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WordPress installation to an add-on domain (4 posts)

  1. bamapachyderm
    Member
    Posted 6 years ago #

    Okay, I've looked everywhere and nothing is answering my problems.
    Background:

    I have a blog at bamapachyderm.com. I just bought an add-on domain from my web host/domain seller (one and the same), let's call it newblog.com.

    I have my bamapachyderm blog set up on the server under /bama/public_html/(wpfolders). I have been TRYING to set up newblog.com as in /bama/public_html/newblog.com/(wpfolders). Using Fantastico, I said to set it up under the newblog.com domain, and it gave me the error(s) located here:
    http://wordpress.pastebin.ca/917187

    So I got rid of that installation and tried again, using bamapachyderm.com as the domain, with newblog.com as the specified folder.

    No problem, WordPress installed just fine. I went to the admin/options and changed the WordPress address and blog URL to newblog.com, because the blog was showing up at bamapachyderm.com/newblog.com/index.php.

    I DO NOT want newblog.com to show bamapachyderm.com at all (if I wanted that, I wouldn't have bothered getting an add-on domain).

    How do I just get newblog.com to show newblog.com? What domain do I install to with Fantastico? Did I have it almost right using bamapachyderm.com, but miss a step?

    HALP?!

    (I also tried a regular installation, but had no better luck than using Fantastico.)

  2. bamapachyderm
    Member
    Posted 6 years ago #

    Also, when I install WP using bamapachyderm.com as the domain it screws up my .htaccess file, taking the following out, which makes my bamapachyderm.com permalinks inaccessible.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    I don't know what my .htaccess file should look like to get it to work properly!

  3. bamapachyderm
    Member
    Posted 6 years ago #

    I figured it out. (I think writing it all down here triggered my thoughts.)

    What I did: I put a separate .htaccess file in the bama/public_html/newblog.com/ directory.

    To recap for others having problems:

    1) Installed to bamapachyderm.com domain under the newblog.com folder,

    2) changed wordpress location in options to bamapachyderm.com/newblog.com,

    3) changed blog URL in options to newblog.com,

    4) put a new .htaccess file in the newblog.com directory (and left the bamapachyderm.com .htaccess file alone--don't touch that file!)

    I hope my headache helps someone else!

  4. bronnie29
    Member
    Posted 6 years ago #

    hey. i'm having an issue with this. i am wanting to set up a /daily-photo wordpress so i can post a photo daily.
    i have set up the subdomain, but how do i set up a MySQL database & install wordpress?
    thanks for your help.

    Bronnie

Topic Closed

This topic has been closed to new replies.

About this Topic