WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Installation Successful but site not showing up (7 posts)

  1. officialspider
    Member
    Posted 3 years ago #

    Hi all,
    I've successfully installed WordPress 3.0.4 in my server but there's a problem that I couldn't figure out. I've installed WordPress in the root folder but whenever I'm trying to open my site in browser by typing http://xyzsite.com/ its only showing the default template of my web host. On the other hand I can fully access my site by typing http://xyzsite.com/wordpress/. I've thoroughly checked my server stats and root folder and wordpress is installed inside the public_html folder.
    Please help me.
    Thanks in advance

  2. molnarm
    Member
    Posted 3 years ago #

    "wordpress is installed inside the public_html folder"
    To make it clear: your public_html folder contains the folders called wp-admin, wp-content and wp-includes?

  3. govpatel
    Member
    Posted 3 years ago #

    You have a place holder that could be index.html or default.html that are put there when a host account is created stays there until you delete the file.

    If you can access wordpress http://xyz.com/wordpress then you have wordpress in a directory if you want to use from Directory then follow this instructions

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

  4. pgreggtx
    Member
    Posted 3 years ago #

    Seen a couple of similar postings so deleted the index.html and default.html. THink i messed up pulling the index.php from another folder. The wpdbase folder from root sites gives me the dashboard - but cant get the site to pull up via root url. Know of a way to get the index/start page reset so to speak? If you go to the root url you see errors.

  5. govpatel
    Member
    Posted 3 years ago #

    You need log in wordpess admin change site url to your domain name.
    then

    copy index.php file that is in wordpress folder along with other wp- files in root and change line 17 add folder.

    I pasted url with instruction above.

  6. pgreggtx
    Member
    Posted 3 years ago #

    WordPress url was changed to domain. Copied all the files in wordpress folder to root. The index.php doesnt seem to be working and returning errors on screen. What is line 17? dont see a folder reference on that line in the index.php if that is what you mean. go to socceraustin.com will see the error. wondering if my index file is messed up. if i go to http://www.socceraustin.com/wpdbase it shows the site. socceraustin.com/wp-admin goes to the admin log on you would expect.

  7. govpatel
    Member
    Posted 3 years ago #

    WordPress url was changed to domain. Copied all the files in wordpress folder to root.

    looks like you have wordpress in a folder wpdbase so you have not copied them over in root.

    So what I need to know is what exactly you want to do you want to use wordpress from this folder and have your wordpress open with this http://www.socceraustin.com

    If this what you want then you need to copy index.php file that is along with all wp- files to root that is in public_html
    Open index.php you just copied in editor and in line 17 add wpdbase so you have

    require('./wpdbase/wp-blog-header.php');
    log in admin
    http://socceraustin.com/wpdbase/wp-admin

    change site url in Settings general to http://socceraustin.com

    and reset your permalinks by clicking on Settings General

Topic Closed

This topic has been closed to new replies.

About this Topic