WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Installation (5 posts)

  1. Roger0x1
    Member
    Posted 7 years ago #

    Configuration: Windows 2003 servers, one web, one dedicated database

    Software on database server is mysql v. 4.1.6 (cause I read that 4.1.7 note).
    Software on the web server is latest download, 2.1.1.

    Error is (amazingly enough)
    Error establishing a database connection
    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at falconsql. This could mean your host's database server is down.

    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?

    Also installed on the web machine is mySql admin tool, which connects just fine using the login information for the blog account.

    The config file contains (passwords cleared for security)

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'wordpress'); // The name of the database
    define('DB_USER', 'wordpressweb'); // Your MySQL username
    define('DB_PASSWORD', '*****************'); // ...and password
    define('DB_HOST', 'falconsql'); // 99% chance you won't need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_1'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    I can ping the database server by name and by IP. I can connect to the database server on port 3306, and Admin tools using the above account works just fine on that port. This leave me .... confused.

  2. Chris_K
    Member
    Posted 7 years ago #

    I should caveat the following by mentioning we don't really support server configuration. That being said...

    Using the mysql admin tool doesn't really troubleshoot your issue. No web server is involved and it seems (to me at least) that usually the issue in a deal like this is mysql <-> php config.

    It'd be more interesting to know if you can connect with phpMyAdmin.

  3. Roger0x1
    Member
    Posted 7 years ago #

    I don't know if this constitutes a true connect, but after a quick configuration, I get:

    Welcome to phpMyAdmin 2.10.0.2

    phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in config.inc.php and make sure that they correspond to the information given by the administrator of the MySQL server.

    Error
    MySQL said:

    #1251 - Client does not support authentication protocol requested by server; consider upgrading MySQL client

    Based on the error message, I'd say that phpMyAdmin had at least some contact to the server to get a rejection message, but I could be wrong. Let me know if I need to go further down this path.

  4. MichaelH
    Member
    Posted 7 years ago #

    You should check the host, username and password in config.inc.php and make sure that they correspond to the information given by the administrator of the MySQL server.

    That's pretty much what WordPress installation said.

    falconsql is different name for mysql server...

  5. Roger0x1
    Member
    Posted 7 years ago #

    ok, I think I have this solved -- the root cause of the database connection error was related to password hashing in mysql. The fix is to reset your passwords using the OLD_PASSWORD function as documented in the mysql help files.

    The gotcha: the help file also says stop that nice service it make for you, and manually launch mysqld.exe --old-passwords.

    Note that if you are using phpMyAdmin, you will get the error message referenced above.

    I hope this helps some of you windows guys out there set this up, I've solved my mystery and I'm off to set up now.

Topic Closed

This topic has been closed to new replies.

About this Topic