WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Index page slow loading (8 posts)

  1. karenj
    Member
    Posted 8 years ago #

    I'm new to this forum so apologies if I am posting in the wrong place. My WordPress blog seems very slow to load compared to the rest of my site. I tried changing the theme to the WordPress standard one and it didn't make any difference. I don't have any plugins, or at least I don't think I do! I think it is maybe a server issue but wondered if anyone could just take a look and tell me if anything else could be contributing. I don't want to fiddle with settings too much because it took me long enough to set the blog up in the first place and I am frightened I will break it!

    http://www.kittyscavern.com/smurfs-blog/

    Thanks

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    -- 18 queries. 3.971 seconds. -->
    -- 18 queries. 3.944 seconds. -->

    It seems to ask for the page, wait, then grab it all at once so my guess is the problem is on the server... but then someone with more knowledge should be along soon :)

    Oh, and upgrade ?
    content="WordPress 1.5.1.2" /

  3. Is your database location on localhost or is it on a different box? If it's on a seperate box, especially if it's connecting via a web address, that's probably the cause.

  4. karenj
    Member
    Posted 8 years ago #

    Sorry to sound thick. How do I know whether it is on localhost? Looking at my control panel there is this connection info, is this relevant? Or is this something I need to ask my hosting people?

    Connection Information: In Scripts please use MYSQLSERVER

    Is the upgrade relatively easy to do? I am really worried about messing things up. Obviously I'll backup first.

    Thanks

  5. In your wp-config.php, what is DB_HOST set to? Mine is define('DB_HOST', 'localhost'); for example.

  6. karenj
    Member
    Posted 8 years ago #

    Oh DUH! I remember that bit now. I vaguely remember having to check that now. This is what I have: -

    define('DB_HOST', 'MYSQLSERVER');

    Was it localhost by default originally? I can't remember? I have a vague recollection that I had to change something to get it to work properly.

  7. Yes, it was localhost by default.

    Anyway, are any other scripts on your site that use MySQL slow?

  8. karenj
    Member
    Posted 8 years ago #

    I've just spoken to my hosting company and apparently there are problems on that server, they are going to move it to a different server for me. Thanks for your help.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags