WordPress.org

Ready to get started?Download WordPress

Forums

WordPress in Own Directory (16 posts)

  1. flyingfish
    Member
    Posted 5 years ago #

    Hi I've recently attempted to publish my site. My problem is that my url purchased through my host will not display my site without using wordpress.com after the original address. I would like to have the original url as my blogsite without using wordpress.com. The hosting company tells me I must uninstall wordpress and redo the settings. Does anyone have any insight into this so they can spell out how exactly to accomplish this without creating a diaster.

  2. MichaelH
    Member
    Posted 5 years ago #

    So you purchased a domain. And you have now purchased a hosting plan. You also have a wordpress.COM blog. But now you want to install WordPress on your own domain, correct?

    Ask your hosting company for their name servers, then visit your domain registrar and make sure the name servers for your domain are set to the values your host provides. Once that is done you may have to wait 8-72 hours for those name servers to proprogate across the internet.

    Then go install WordPress on your hosted domain.

    If you have more questions please provide this information:
    Who is your domain registrar?
    Who is your host?
    What is your domain name?

  3. flyingfish
    Member
    Posted 5 years ago #

    I think you are understanding me. I just want my url as follows http://www.globaldrug debate.com, the url I purchased from godaddy.com. My url with the worpress installed in my host root directory is http://www.globaldrugdebate.com/worpress. I'd like to keep the original url. Therefore I must put wordpress I a subdomain, is what the host has indicated.

  4. MichaelH
    Member
    Posted 5 years ago #

    To make WordPress available at http://www.globaldrugdebate.com just change in Settings->General, the Blog address (URL) to http://www.globaldrugdebate.com (leave the WordPress Address as is) and put this index.php file in your web-root folder (it is the same folder that contains the wordpress folder)

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wordpress/wp-blog-header.php');
    ?>

    Then update your permalinks in Settings->Permalinks.

  5. flyingfish
    Member
    Posted 5 years ago #

    Thanx MichaelH I'll let you know how that goes for me!!

  6. flyingfish
    Member
    Posted 5 years ago #

    MichaelH I did exactly what you instructed me to do with regard to your last post. However the page still does not load the blog. My host told me that my web root folder is my url. Using FTP I uploaded the index.php file to my url, then updated my permalinks, still to no avail. Is it possible that I must download wordpress completely an then upload it to a subdomain? If so how can I accomplish this?

  7. MichaelH
    Member
    Posted 5 years ago #

    Are you sure the index.php in your html folder is exactly as I described above?

    I'd guess you copied the index.php from something like the themes/default folder and that would be wrong!

  8. flyingfish
    Member
    Posted 5 years ago #

    I copy and pasted it created a file and FTP it. Correct?

  9. MichaelH
    Member
    Posted 5 years ago #

    Yes but the error Fatal error: Call to undefined function get_header() in /home/content/r/a/g/ragingbull4/html/index.php on line 1 is a result of something incorrect in the index.php file that is in your web-root folder.

    Delete what is there, then upload the file from your local machine after you check that the copy on your local machine is correct as I described above.

  10. flyingfish
    Member
    Posted 5 years ago #

    I have a larger problem now, after being given a code from godaddy I uploaded it and went into permalinks and I beleive that I erased the /wordpress from the wrong url. My site is now displaying in a white background and I cant't access the wp-admin to fix problem. Any ideas?

  11. flyingfish
    Member
    Posted 5 years ago #

    I have disabled my /wordpress url and cannot get into my wp-admin and my site is not displaying the theme. How do I using the host go into my database to restore my /wordpress url? Hopefully there is a method!!!

  12. MichaelH
    Member
    Posted 5 years ago #

  13. flyingfish
    Member
    Posted 5 years ago #

    Thanx for the url MichaelH, I was able to restore the /wordpress from the back door. Now I'll take my time and go back to some of the earlier instructions you gave me and bring my initial request to fruition. Thank-you again

  14. mjensen
    Member
    Posted 5 years ago #

    I'm having the same original question. But unsure how to do this::

    "put this index.php file in your web-root folder (it is the same folder that contains the wordpress folder)

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wordpress/wp-blog-header.php');
    ?>
    Then update your permalinks in Settings->Permalinks."

    I'm on godaddy as well.

    Thanks.

  15. groovyKimo
    Member
    Posted 5 years ago #

    Google for "what is web root folder". That should explain it.

  16. flyingfish
    Member
    Posted 5 years ago #

    Resolved thanx MichaelH and members!!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.