WordPress.org

Ready to get started?Download WordPress

Forums

WordPress ignoring permalink structure (14 posts)

  1. xrlq
    Member
    Posted 8 years ago #

    I just upgraded to 2.0 and now the permalinks don't work unless I use the "default" setting. If I use "Date and name based," my preferred option, the permalinks all display correctly on the blog, but if I follow them, I end up with the main index view of the front page. It does, however, display the intended permalink in the URL window.

    I tried renaming my old .htaccess file in case there was something in there that might be confusing WP 2.0, and then rebuilding the permalink structure, but that didn't seem to help.

  2. newflesh
    Member
    Posted 8 years ago #

    I have the exact same problem. All links just load the index, no matter if it's a link to a post, page or archive page.

    I also tried to let WP create a new .htaccess, but that doesn't do anything.

    If it's to any help, here's the .htaccess it creates:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php
    </IfModule>

    # END WordPress

    I have a test install running 1.5.2 at the same host, and since that could rebuild permalinks just fine I'm pretty sure it's related to the new WP version rather than anything server side.

  3. vkaryl
    Member
    Posted 8 years ago #

    There are numerous threads about this (some of the better ones are in the list of recent threads on the "front page", matter of fact). There are various solutions posited in them, some of which even work.

  4. BillyG
    Member
    Posted 8 years ago #

    damn man, where, I've been screwed since this morning, HELP US PLEASE!

  5. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    To help us debug, download, install, and activate the Dump Env plugin. Visit a page that is giving a 404. Save the page source for that page. Forward the page source to ryan at boren dot nu. Deactivate the plugin when finished.

  6. Marc
    Member
    Posted 8 years ago #

    ryan I've been having a similar problem although a little worse.

    My index won't even show after the upgrade, nothing but 404's on everything except dashboard/admin functions.

    I noted the Dump Env plugin in the other thread and all the source returned after install and activation of it was the 404 msg text.

  7. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    In that case, WP isn't even being run. The server is issuing the 404, not WP. Is this with htaccess? Try this plugin that reverts back to the long-form rewrite rules. Activate the plugin, visit Options->Permalink to update .htaccess, and then visit a page. Any better?

  8. Marc
    Member
    Posted 8 years ago #

    Yes it is with htaccess.

    Give me a few and I'll give the plugin a go. Also note the the code "Newsflash" has posted above is also how it appears on my blog no matter what structure I use.

    Anyway give me a few.

  9. newflesh
    Member
    Posted 8 years ago #

    I'm not getting any 404's at all. I just get the main page, no matter what I do. Any hints (other than using basic links, which works but of course leaves me without permalinks).

    It does something, that's for sure, for even when I've changed back to the basic links it shows index.php for any wrong URIs entered.

    /edit: the verbose plugin seems to fix the problem. Didn't notice that before I posted.

  10. Marc
    Member
    Posted 8 years ago #

    No luck ryan.

    This is the same before and after the verbose plugin was activated.


    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^pickledpundit.cranialcavity.net$ [OR]
    RewriteCond %{HTTP_HOST} ^www.pickledpundit.cranialcavity.net$
    RewriteRule ^(.*)$ /pickledpundit/index.php [R=301,L]

    And note this blog is on a sub-domain, which is cranialcavity.net

  11. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    Marc, do you have any other plugins that change rewrite rules? WP doesn't write rules like that by default or with my plugin.

  12. Marc
    Member
    Posted 8 years ago #

    Not that I can tell, but I'm far from an expert.

    Here is what is installed. The only two new ones, obviously, are Akisment and WordPress Database Backup

    WeatherIcon
    Akismet 1.12
    Bad Behavior
    Blogs Of The Day
    Comment Quicktags
    FancyTooltips
    Gravatar Signup 1.5
    Gravatar 1.2
    Headline Images 2.4
    Recent Comments List
    KG Archives 1.0
    Live Comment Preview
    Markdown 1.0
    RunPHP 1.2b3
    Subscribe me
    Simpsons Quote
    Subscribe To Comments
    Textile 1 1.0
    WordPress Database Backup

  13. The_Magistrate
    Member
    Posted 8 years ago #

    @ryan --

    Thanks for the plugin. It worked in my case. I just needed to be able to edit the .htaccess file to add a few things. I didn't install wordpress in the root of my site, and making it point to the right directory was a pain to get working. The new permalink system screwed up my system, and your plugin fixed it.

    Thanks.

  14. xrlq
    Member
    Posted 8 years ago #

    Ryan's plugin to force the verbose rewrite rules appears to have worked. Is that the permanent solution, or is there a way to make the newer rules work instead now that we've isolated the problem?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags